iLLuSi0nS

Active Member
Jun 9, 2007
43
0
156
I wanted to try out ClamAV so I went to WHM > Manage Plugins - And installed ClamAVconnector but in the description for the software it said

Version: 0.93.1p-2.0.4
Description: !!BETA VERSION!!

Is this bad? Should I have not installed it?

ALSO, while I was installing it and it gives a readout on your browser of what the installer is currently doing, It was doing its thing, and it was taking a long time, about 2 minutes or so, and firefox crashed for some reason before it was fully done installing.

My question is, once you start the installation of Clamavconnector through whm, is keeping the browser open a requirement? or will it install whether or not you keep your browser open or not.

Thanks
 

Bdzzld

Well-Known Member
Apr 3, 2004
412
5
168
I wanted to try out ClamAV so I went to WHM > Manage Plugins - And installed ClamAVconnector but in the description for the software it said

Version: 0.93.1p-2.0.4
Description: !!BETA VERSION!!

Is this bad? Should I have not installed it?
This plugin has been *beta* for many years. Just ignore the "warning". It will not have any additional problems.

ALSO, while I was installing it and it gives a readout on your browser of what the installer is currently doing, It was doing its thing, and it was taking a long time, about 2 minutes or so, and firefox crashed for some reason before it was fully done installing.

My question is, once you start the installation of Clamavconnector through whm, is keeping the browser open a requirement? or will it install whether or not you keep your browser open or not.

Thanks
Keeping the browser open is not a requirement. Just check back after an hour or so and you'll notice it has been installed without problems (it usually does if you've cPanel Pro already installed).
 

iLLuSi0nS

Active Member
Jun 9, 2007
43
0
156
Thanks, It did install, but I was afraid maybe it didnt completely install since my browser crashed and I was afraid that it might be corrupt or not work correctly
 

Bdzzld

Well-Known Member
Apr 3, 2004
412
5
168
Nope. The browser does not interfere with the processes that are being started by WHM.
The browser is just used to show the output/status... that's all...
 

alex318

Member
Jun 4, 2005
11
0
151
furquan, the same has already been added to this thread a few years ago (second post) and does not upgrade, but installs a new version. Please follow the guidelines as described later to upgrade...
Thanks for the tips. I follow your guide posted here and upgrading process have been very smooth. I have a latest clamav version now!
 

mealto

Well-Known Member
Oct 20, 2006
175
0
166
When I get to this stage:

**************
Now execute

/install2
**************

I am getting this error:

**************
-bash: install2: command not found
**************
Any ideas how to execute install2?

Trying to upgrade this:

AVV=0.93.1
AVVOLD=0.93
 

Radio_Head

Well-Known Member
Verifed Vendor
Feb 15, 2002
2,048
1
343
How to upgrade to 0.93.3
( this guideline should work on most OS and probably also for future clamd versions > 0.93.3 )
# cd /usr/local/cpanel/modules-install/clamavconnector-Linux-i686

or only if you have OS64

# cd /usr/local/cpanel/modules-install/clamavconnector-Linux-x86_64

then..

# wget http://freshmeat.net/redir/clamav/29355/url_tgz/clamav-0.93.3.tar.gz
# cp install install2
# chmod 755 install2


now check your clamd version
# clamd --v

for example it returns 0.93

now

# pico install2

and replace

AVVOLD=0.90.2
with your current version (the value returned above 0.93)

and
AVV= with newer version (get it correctly from the clamav file downloded above) , in this case 0.93.3

so you should have this
AVV=0.93.3
AVVOLD=0.93

Save


Now execute

# ./install2

After few minutes , you should have 0.93.3 .

You can check the version with
# clamd --v



Done!
 
Last edited:

pcsousa

Well-Known Member
May 28, 2004
63
0
156
Ty Radio.

Made it with success.

I've got follwing message, even with APF down, but seems clamd is now up and running.

ClamAV update process started at Mon Jul 14 17:58:13 2008
main.cvd is up to date (version: 47, sigs: 312304, f-level: 31, builder: sven)
WARNING: getfile: daily-7652.cdiff not found on remote server (IP: 62.26.160.3)
WARNING: getpatch: Can't download daily-7652.cdiff from database.clamav.net

nonblock_connect: connect timing out (30 secs)
Can't connect to port 80 of host database.clamav.net (IP: 213.209.100.191)
Trying host database.clamav.net (62.26.160.3)...
WARNING: getfile: daily-7652.cdiff not found on remote server (IP: 62.26.160.3)
WARNING: getpatch: Can't download daily-7652.cdiff from database.clamav.net
WARNING: getfile: daily-7652.cdiff not found on remote server (IP: 213.174.32.130)
WARNING: getpatch: Can't download daily-7652.cdiff from database.clamav.net
WARNING: Incremental update failed, trying to download daily.cvd
Downloading daily.cvd [100%]
daily.cvd updated (version: 7709, sigs: 39397, f-level: 33, builder: neo)
Database updated (351701 signatures) from database.clamav.net (IP: 212.1.60.18)
clamd: no process killed
clamd: no process killed
Starting chkservd: [ OK ]
(...)
 

Bdzzld

Well-Known Member
Apr 3, 2004
412
5
168
Looks like a temporary failure to download updates. This happens occasionally. It will probably be solved the next time the update sequence runs.
 

Radio_Head

Well-Known Member
Verifed Vendor
Feb 15, 2002
2,048
1
343
it's normal , 0.93.3 is now available on WHM too.
 

Bdzzld

Well-Known Member
Apr 3, 2004
412
5
168
The original scheme, which is located here (a.o) does not seem to work for upgrading version 0.93.3 to 0.94.
 

opt2bout

Well-Known Member
Nov 10, 2006
69
1
158
.93.3 to .94 update worked

The original scheme, which is located here (a.o) does not seem to work for upgrading version 0.93.3 to 0.94.
First, thanks for the link. I have been getting freshclam update errors, I'm hoping the update to 0.94 fixes it.

I was able to follow the instructions and it worked on my RHEL 4 box (686).
 

Bdzzld

Well-Known Member
Apr 3, 2004
412
5
168
Code:
# wget http://downloads.sourceforge.net/clamav/clamav-0.93.tar.gz
How stupid... forgot to change this to 0.94 to reflect the new version... That's why my own scheme did not work... lol :p
 

rrwh

Well-Known Member
Oct 2, 2004
48
0
156
bump - 0.94.2 has been released and Cpanel is lagging - follow the instructions previously given except remember to update the file that you download, and the 2 variables in the install script before you run it.