WHM Console may_create_sym_link1 error

thowden

Well-Known Member
May 17, 2013
86
14
58
Australia
cPanel Access Level
Root Administrator
Hi All

I am seeing a console error message
may_create_sym_link: can't find ea-php56 in cronjobs

This is repeating and has some variations, occassionally ea-php72 is not found

I have updated to the latest CPanel / WHM patch today to see if that fixes, but no.

I have searched the terms in the error but cannot find anything that appears to relate.

Any pointers please.

Thanks.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,903
2,237
463
Hello @thowden,

Can you open a support ticket so we can take a closer look at the affected system to see what's happening? You can post the ticket number here and I'll link this thread to it.

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,903
2,237
463
Hello,

To follow-up on this, this can occur when the following kernel option is enabled in the /etc/sysctl.conf file on CloudLinux systems (as part of the Link Traversal Protection feature):

fs.protected_symlinks_create = 1

CloudLinux warns against enabling the above kernel option on cPanel & WHM servers on the following document:


Note that specific to the warning message reported on this thread, the console output doesn't result in a loss of functionality. For more information about why these specific symlinks exist, see the document below:


Thank you.
 

thowden

Well-Known Member
May 17, 2013
86
14
58
Australia
cPanel Access Level
Root Administrator
Hi

Funny how things come around, I just had a similar error and a Google search brings me back to my own thread that I had forgotten about.

@cPanelMichael thanks for the response, I had missed it entirely.

I have just checked, as much as I can, and the kernel is not compiled with that feature, albeit that the kernel is now a later version.

I checked in the /etc/sysctl.conf file and it is silent for that option. I also checked via

#cat /lib/modules/$(uname -r)/build/.config | grep SYMLINKS ## (also symlinks)

but that setting is not found (maybe that is not the correct location to check?)

My error today was displayed when I opened the XenConsole to access the VM terminal for this CPanel server. In my haste I omitted to screenshot it but the error was essentially the same but reporting "can't find ea-php72 in " various directories.

From the documentation at CloudLinux which is linked above, it appears possible that while the

fs.protected_symlinks_create = 1

option is not explicitly configured in the /etc/sysctl.conf file, it may be a default setting in this current build ?

In any case, I am going to set it explicitly as 0 which I assume will turn it off, if it is on by default.

Addendum:

While I was going to set this off, I then found an issue with 100% inode use on one of the drives, notably /home which is on its own drive. From memory the "can't find message from this morning was reporting files that would / should have been accessed in /home and I am now thinking that the error is in fact relating to the 'out of space' error caused from lack of inodes.

I'll update this later.
 

thowden

Well-Known Member
May 17, 2013
86
14
58
Australia
cPanel Access Level
Root Administrator
Hi

I am still getting these error / warnings at the root console may_create_sym_link: can't find ea-php72 in xxxxxxx (repeated with various directories).

sym_link_warning.png

The inode issue was apparently irrelevant.

I'll try the

fs.protected_symlinks_create = 0 setting at the weekend.