The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WHM Cpanel File permission/ownership problem.

Discussion in 'General Discussion' started by frozenice, Apr 22, 2010.

  1. frozenice

    frozenice Registered

    Joined:
    Apr 22, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    hi,

    badly need help...

    Currently im managing 3 dedicated host w/ whm cpanel..

    now, one of those 3 got me a big headache, ssh and mysqld not working and a very big prob.. i just found out that root directory "/" was owned a user and not the root..

    i mean..

    /etc
    /var
    /home

    etc...

    apache is running good.. ftp is ok.. but cannot login as a root.
    i created user edited the /etc/sudoers to grant root access as sudo
    but i cannot exec sudo on a php backdoor shell..

    question:
    should restoring the backup will correct the file ownership/permission?
    is there a tweak to make sshd run? so i can change the ownership problem?
    any feature or tool inside cpanel to correct the issue, or even just to grant sshd to run?


    as much possible we dont want to have a os reinstall as we cannot afford for a downtime and there are about 1TB of important files..

    any suggestion and ideas would greatly be appreciated.


    OS:
    Centos 5.4


    Best regards,
    richard.
     
    #1 frozenice, Apr 22, 2010
    Last edited: Apr 22, 2010
  2. garrettp

    garrettp Well-Known Member
    PartnerNOC

    Joined:
    Jun 18, 2004
    Messages:
    312
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    DataCenter Provider
    The situation you are describing sounds as though you may be dealing with a root-level intrusion. If this is the case, your only real recourse is to backup your data and do a fresh OS install. You should also have an experienced sys admin take a look at matters before doing anything drastic however.
     
  3. frozenice

    frozenice Registered

    Joined:
    Apr 22, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    hi garret,

    thanks for the fast reply men,...
    im really messed up here..

    this is really though thou..

    still hoping to for someone to throw some ideas..
    anyway, if any trys under any circumstances then we'l reinstall OS maybe if failed..


    anyway, can i run sshd even on different not a root user? i did already chmod 777 .. but.. failed.. tried restarting from whm but failed.


    best regards,
     
Loading...

Share This Page