whm/cpanel/webmail opening up defaultwebpage.cgi instead of what it should be.

TechRandy

Registered
Jun 5, 2014
2
0
1
cPanel Access Level
Root Administrator
whm/cpanel/webmail are all on the fritz, they all open up to /cgi-sys/defaultwebpage.cgi
I have WHM 11.42.1 (build 17)
I have ran other peoples fixes on these forums such as /usr/local/cpanel/bin/build_apache_conf
none has worked. I have checked dns record and it shows to be correct A records for each pointing to the domain ip.
I even tried to set:
cpanel 3600 IN CNAME domain.net/securewhm.
whm 3600 IN CNAME domain.net/securecpanel.

This did not resolve the issue. We have 2 whm/cpanel servers the other is working fine and i've compared the dns records and everything looks fine.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,202
363
Hello :)

Please verify that proxy subdomains are enabled on your system:

"WHM Home » Server Configuration » Tweak Settings"

The option is titled "Proxy subdomains" under the "Domains" tab.

Thank you.
 

TechRandy

Registered
Jun 5, 2014
2
0
1
cPanel Access Level
Root Administrator
Ohh it was off because Configserver CSF firewall recommended it be off.
Do i need to restart a service after turning it back on?

- - - Updated - - -

got it, it's working fine now

- - - Updated - - -

Thank you for your quick assistance. Any clue why configserver firewall recommends it be off?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,202
363
I am happy to see the issue is now resolved. You should consult directly with ConfigServer or their support forums for clarification on why exactly they suggest disabling this feature.

Thank you.