The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WHM, cPanel, WebMail very slow to load

Discussion in 'E-mail Discussions' started by jnetsurfer, Nov 1, 2007.

  1. jnetsurfer

    jnetsurfer Member

    Joined:
    Feb 20, 2004
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    I have just setup a fresh, new VMWare Virtual Machine with CPanel 11.15.0. Most of the time, the server runs great.

    However if I try to load WHM or cPanel or WebMail, the server pretty much locks up. Load goes way up (from 0.1 to 5 or higher) and almost all services stop reponding.

    What's going on? Do i need to configure cPanel differently if it's running inside a virtual machine?

    Pleas let me know if you need more information (server specs, etc).

    -Josh
     
  2. apn3a

    apn3a Member

    Joined:
    Oct 25, 2007
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    i have the same exact issue. everything goes SO slow, cpanel, whm, websites (even the plain html ones). once i restart the server or httpd/mysql everything works great for a fraction of a second. I'm on a split-dedicated vps with 2gb of ram and 4 Intel core 2 duo quad core cpus. When i type the address for whm or cpanel so i can loggin, it pops up INSTANTLY. when i enter username and pass it takes FOREVER to load.

    WHM 11.11.0 cPanel 11.15.0-R17853
    CENTOS Enterprise 5 x86_64 on virtuozzo - WHM X v3.1.0
    php 5.2.4
    apache 2.2.6 via easyapache
    mysql 5.0.27

    I run the RELEASE update.
     
  3. ljweb

    ljweb Member

    Joined:
    Nov 26, 2003
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Anyone have any ideas on this? Im having the same issue on vmware, very slow to load cpanel & whm, regular http and mail works fine, just the cpanel stuff is very slow!.
     
  4. jnetsurfer

    jnetsurfer Member

    Joined:
    Feb 20, 2004
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    ljweb,

    Do you also experience sporadic server slowdowns? That's my other issue. Every now and then all sites get slow and heartbeat drops. It happens when people load WHM / cPanel sometimes.

    Do you get high iowait% on your host system?

    -Josh
     
  5. jnetsurfer

    jnetsurfer Member

    Joined:
    Feb 20, 2004
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Possible SOlution

    I made the following changes to my VMWare VMs and the server slowness seems to be drastically reduced:

    - Added 1 GB of RAM to the VM
    - Added the following to the .vmx config file:

    sched.mem.pshare.enable = "FALSE"
    mainMem.useNamedFile = "FALSE"
    MemTrimRate = "0"
    MemAllowAutoScaleDown = "FALSE"

    - Added the following to my vmware server config file:

    prefvmx.useRecommendedLockedMemSize = "TRUE"
    prefvmx.minVmMemPct = "100"


    I did that last week, performance has been much better this week.
     
Loading...

Share This Page