The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

whm crash my server

Discussion in 'General Discussion' started by Nikoms, Dec 31, 2006.

  1. Nikoms

    Nikoms Member

    Joined:
    Nov 29, 2006
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Hello everybody!

    It seems that i have a little problem with WHM. I just upload a new website on my server. And it works, but, now when i'm going to the whm panel :)2086), my server slow down. SSH comes very slow, and mysql crash (i receive a mail mysql failed @ Sun Dec 31 19:00:11 2006. A restart was attempted automagicly.)


    here the first lines of a "top" during the connection :

    top - 19:03:19 up 1:28, 1 user, load average: 17.89, 9.10, 5.05
    Tasks: 100 total, 1 running, 99 sleeping, 0 stopped, 0 zombie
    Cpu(s): 2.4% us, 2.7% sy, 0.0% ni, 0.0% id, 94.5% wa, 0.3% hi, 0.0% si
    Mem: 239352k total, 236292k used, 3060k free, 416k buffers
    Swap: 0k total, 0k used, 0k free, 7172k cached


    The browser can't display whm. So i quit IE.

    If I do nothing during 1 minutes, and then do "top", here is the result :

    top - 19:08:37 up 1:33, 1 user, load average: 0.22, 3.60, 3.86
    Tasks: 97 total, 2 running, 95 sleeping, 0 stopped, 0 zombie
    Cpu(s): 0.0% us, 0.5% sy, 0.0% ni, 99.5% id, 0.0% wa, 0.0% hi, 0.0% si
    Mem: 239352k total, 234624k used, 4728k free, 1160k buffers
    Swap: 0k total, 0k used, 0k free, 17692k cached




    I really don't understand... I already made a upcp --force, but it didn't change anything.

    Did anyone have the same problem? Do you know what can it be?

    Thanks a lot!

    EDIT :

    Sometimes i got a "Lost connection to MySQL server during query" message and when i refresh i got "Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)"

    Is that normal that i have this, in my "top"?

    3007 nobody 16 0 27444 12m 348 S 2.0 5.4 0:08.54 /usr/local/apache/bin/httpd -DSSL
    2634 nobody 16 0 27584 12m 348 S 1.9 5.4 0:05.61 /usr/local/apache/bin/httpd -DSSL
    2580 nobody 16 0 26460 11m 344 S 1.9 5.0 0:03.06 /usr/local/apache/bin/httpd -DSSL
    2582 nobody 16 0 27092 12m 440 S 1.9 5.3 0:08.51 /usr/local/apache/bin/httpd -DSSL
    2583 nobody 16 0 26056 11m 348 S 1.9 4.8 0:06.07 /usr/local/apache/bin/httpd -DSSL
    2585 nobody 16 0 26928 12m 348 S 1.8 5.2 0:05.98 /usr/local/apache/bin/httpd -DSSL
    3030 nobody 16 0 27176 12m 348 S 1.8 5.2 0:04.25 /usr/local/apache/bin/httpd -DSSL
    5894 nobody 16 0 24824 9.9m 516 R 0.8 4.2 0:00.22 /usr/local/apache/bin/httpd -DSSL
    5886 nobody 16 0 25740 10m 376 R 0.7 4.7 0:00.24 /usr/local/apache/bin/httpd -DSSL
    5910 nobody 17 0 24560 9976 468 R 0.6 4.2 0:00.17 /usr/local/apache/bin/httpd -DSSL
     
    #1 Nikoms, Dec 31, 2006
    Last edited: Dec 31, 2006
  2. mohit

    mohit Well-Known Member

    Joined:
    Jul 12, 2005
    Messages:
    553
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Sticky On Internet
    hi,
    seems you have a busy site cause your usage shows Apache is serving many request.
    they could be using a lot of mysql and finally crashing.

    you can ask a sys admin to look into this properly cause memory usage seems high and swap usage is not visible.

    you can however try these from ssh

    mysqladmin processlist |wc -l

    above will show you active mysql connections.

    ps aux | head -1;ps aux --no-headers| sort -rn +3 | head
    above would show you top memory consuming processes.

    have you tried killing all mysql process and restarting the mysql service ?

    see ya,
    mohit
     
  3. Nikoms

    Nikoms Member

    Joined:
    Nov 29, 2006
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Thank you mohit (and happy new year :) )


    I try you command in ssh :


    ps aux | head -1;ps aux --no-headers| sort -rn +3 | head


    mysqladmin processlist |wc -l

    Sometimes it's 5, sometimes 6 and sometimes 7 :)

    And then... Ite became very slow... And i get this

    And then of course :

    Then the server stop freezing, but mysql is down. So I (re) start mysql, and again and again :)

    My server crash every 9 minutes and x secondes.. So bizarre


    EDIT

    I found this in my "/var/lib/mysql" error file:

    This append verytime the server crashes
    And ate the end of the file I see :

    My server has 256Mb ram, but I only have 1 website on it, so i think it's enough no?


    Thanks for your help :p

    And happy holiday
     
    #3 Nikoms, Jan 1, 2007
    Last edited: Jan 1, 2007
  4. Nikoms

    Nikoms Member

    Joined:
    Nov 29, 2006
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    I found this in my logwatch... Maybe it's important :)

    WARNING: Kernel Errors Present
    <c04036e3> error_code+0x4f/0x54 ...: 174 Time(s)
    <c04036e3> error_code+0x4f/0x54 ...: 1 Time(s)
    <c05ecc16> do_page_fault+0x0/0x597 <c04036e3> error_code+0x4f/0x54 ...: 403 Time(s)
    agpgart-via: probe of 0000:00:00.0 failed with error -22 ...: 3 Time(s)
     
  5. weedy

    weedy Member

    Joined:
    Oct 7, 2006
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    ahh the joys of failing hardware. check dmesg and grep your logs for other errors. also upgrade your kernel. if it doesn't go away looks like you may need to buy new part(s)
     
Loading...

Share This Page