The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WHM doesn't save changes across configuration editors?

Discussion in 'E-mail Discussions' started by quanin, Aug 30, 2012.

  1. quanin

    quanin Well-Known Member

    Joined:
    Aug 18, 2011
    Messages:
    84
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    If I make a change in the basic Exim configuration editor, then switch over to the advanced editor because I need to route mail for one or more domains differently, any changes made in the basic editor are lost. This results, sadly, in me having to go back through the basic editor and reset everything. Strangely enough, the changes I make in the advanced editor, to my knowledge, are not lost when I switch back to the basic. Am I not doing something right when switching, or is this a bug in WHM? I'm running 11.32.4.14 if that helps at all.
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,470
    Likes Received:
    198
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    When you switch to Advanced mode, it's a whole other screen of course. Since you did not choose to save the changes before moving to the other page, they got ignored.
    Not sure I'd want to be going back and fourth like this out of concern that something might go wrong. (or changes get lost as you describe)

    Saving changes and then moving on works properly though, correct?
     
  3. quanin

    quanin Well-Known Member

    Joined:
    Aug 18, 2011
    Messages:
    84
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    Actually I was saving my changes, then going back and into the advanced editor. And on further examination, the only change that didn't save even after yes, I did tell it to, was the spam rejection settings--I'd set it to reject with a spam score of 5 or greater, save it, go back to that screen, confirm it's still set there, switch to the advanced editor, make my changes, save those changes, then go back to the basic screen. My rejection settings would be back to the default. Which is awesome, except the default is to not reject spam at the server level. And apparently I see a lot of spam. So you can probably see how that might be a touch concerning.
     
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Hello,

    Could you submit a bug report of this behavior to http://go.cpanel.net/bugs location? I do see internal case 59678, but I'm uncertain if the setting you are changing is noted in that case as I don't see a spam rejection one in it. The case is about how some changes in the basic editor aren't being retained after saving them if you go to the advanced editor afterward, which is what you are describing.

    At the very least, we can flag your ticket to the case as another person noticing this behavior who has been impacted by it.

    Thanks!
     
  5. quanin

    quanin Well-Known Member

    Joined:
    Aug 18, 2011
    Messages:
    84
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    See ticket #3107919
     
Loading...

Share This Page