WHM Email All Users doesn't like apostrophes

Metro2

Well-Known Member
May 24, 2006
522
74
178
USA
cPanel Access Level
Root Administrator
WHM > Account Functions > Email All Users

Just sent out an announcement to my customers only to find that every instance of words with apostrophe looks bad.

Example:

The phrase "Hello, we're working on..." reached all my customers looking like "Hello, we're working on..."

It looks bad and unprofessional in a "my web host can't even get their newsletter to work right" sort of way.

Any chance we can get WHM > Account Functions > Email All Users to understand / parse English punctuation?

Thanks for any attention cPanel devs can give to this issue.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,227
463
Hello :)

Messages sent from this interface are UTF-8 encoded, however email clients might expect the message to define a specific content type, and the result when that does not happen can lead to the issue you are describing.

Thank you.
 
Last edited:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,227
463
Hello :)

I've updated my previous response, as it's only the "Guess Email Addresses" functionality of this option that's removed in cPanel version 56:

56 Release Notes - Documentation - cPanel Documentation

I suggest opening a feature request for a more robust contact users option if you would like the ability to choose specific format options when sending the messages:

Submit A Feature Request

Thank you.
 

Metro2

Well-Known Member
May 24, 2006
522
74
178
USA
cPanel Access Level
Root Administrator
Thank you for the suggestion cPanelMichael.

Just FYI - I'm not trying to do any custom formatting at all.

Just plain text typed directly in to the "Email Users" feature in cPanel the way I've always done for many years.

The only issue is that in recent versions of WHM the "Email Users" feature has started replacing apostrophes with code characters.

Everything else appears to be fine when I use the feature, but if I type in a word like "we're" and hit send, my users receive we're instead of we're .

I'm not doing any copy & paste or any special formatting. Just typing in a basic plain text message into the "Email Users" message box in WHM.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,227
463
Hello,

I've opened internal case CPANEL-6075 to report this behavior. I'll update this thread with more information on the status of this case as it becomes available.

Thank you.
 
  • Like
Reactions: Metro2

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,227
463
Hello,

To update, the resolution to this issue is scheduled for inclusion with cPanel version 58.

Thank you.
 
  • Like
Reactions: Metro2