The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

whm ftp login

Discussion in 'General Discussion' started by sniperscope, Mar 20, 2013.

  1. sniperscope

    sniperscope Well-Known Member

    Joined:
    Apr 5, 2011
    Messages:
    118
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    osaka/ japan
    cPanel Access Level:
    Website Owner
    Hello
    I want to login whm via filezilla but i have no chance, even i shut down CSF firewall.
    Why i need to login via ftp? because i want download back up files.
    How can i do that? I really appreciate any help.
    Regards
     
  2. CitizenK

    CitizenK Well-Known Member

    Joined:
    Jun 5, 2012
    Messages:
    64
    Likes Received:
    1
    Trophy Points:
    8
    Location:
    On The Road
    cPanel Access Level:
    Root Administrator
    It appears that you want to enable root ftp login. Some ftp server do not support this due to security concerns. A more secure method of accessing your server to download backups is via sftp (ftp over ssh). You can use this in Filezilla (and some other ftp clients) by accessing your server using sftp://your-domain-name.tld If you are using an non-standard port for ssh you will need to specify that in your ftp client as well.

    To answer your original question, you can enable root ftp login in Home >> Service Configuration >> FTP Server Configuration. You will want to set "Allow Logins with Root Password" to Yes, and then save this page.

    Thanks!
     
  3. sniperscope

    sniperscope Well-Known Member

    Joined:
    Apr 5, 2011
    Messages:
    118
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    osaka/ japan
    cPanel Access Level:
    Website Owner
    Dear cpCitizenK
    Thanks for reply. I did you said and i got error.
    Error message from filezilla and configuration screen shot are below for your consideration.

    Status: Connecting to 111.222.333.444:2xxx...
    Response: fzSftp started
    Command: open "root@111.222.333.444" 2xxx
    Error: Disconnected: No supported authentication methods available (server sent: publickey,gssapi-with-mic)
    Error: Could not connect to server

    Untitled-1.jpg
     
  4. arunsv84

    arunsv84 Well-Known Member

    Joined:
    Oct 20, 2008
    Messages:
    373
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    127.0.0.1
    cPanel Access Level:
    Root Administrator
    Hi,

    Whats the error in /var/log/secure and /var/log/messages ?

    Could you please paste it here?

    Cheers!!!
     
  5. Phincy

    Phincy Member

    Joined:
    Feb 11, 2012
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi sniperscope,

    I assume 2xxx is a dummy and you are using the correct SSH port(?) .

    Are you able to directly ssh to the server as root? As the error says, the server is allowing on the following authentication methods.

    (publickey,gssapi-with-mic)

    So, make sure you have proper SSH keys installed in your local computer for staring the SFTP connection to the server. If not, try adding the key or enable SSH password authentication via the section Home >> Security Center >> SSH Password Authorization Tweak in the WHM.
    If still the issue persists, we will need the info arunsv84 mentioned earlier.

    Best regards,
     
  6. sniperscope

    sniperscope Well-Known Member

    Joined:
    Apr 5, 2011
    Messages:
    118
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    osaka/ japan
    cPanel Access Level:
    Website Owner
    Hello guys
    Thank you for your help and post.
    I solved my problem already but forgot to post here.

    Regards
     
Loading...

Share This Page