The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WHM Hangs When Chaning Username for an Account

Discussion in 'General Discussion' started by PedroR, Jan 12, 2011.

  1. PedroR

    PedroR Registered

    Joined:
    Jan 12, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hi

    We're running CPanel/WHm version 11.28.64 on CenTOS 5.5


    We needed to change a Username for an account and went to: - Account Functions > - Modify an Account
    Selected the Account and entered a new Username. Clicked to Save the change.

    1) The first time we did this everything went smoothly and the everything was moved and migrated.

    2) We later had the need to change this Username once again and repetead the procedure .


    This second time the procedure Halted/Locked up and did not finish (WHM seems to Lock up at the screen that says "Saving Account Settings" and shows a progress bar moving indefinitelly). We left it running for some time but then gave up and just restarted the server.

    After restarting, we got this:
    - 10 out of 14 SQL databases were migrated
    - The Home folder was NOT migrated
    - FTP access still seems to be working with the old username

    We tried repeating the procedure after rebooting but the result is always the same (Lock up and the procedure won't finish).

    We're now stuck with this partly migrated account.

    Is there any logs we should look at to see what went wrong or a way to roll back the changes?


    Thanks
    Pedro
     
  2. jack01

    jack01 Well-Known Member

    Joined:
    Jul 21, 2004
    Messages:
    200
    Likes Received:
    0
    Trophy Points:
    16
    Same problem here... did you resolve it? If so how please.

    Thanks
     
  3. cPanelJared

    cPanelJared Technical Analyst
    Staff Member

    Joined:
    Feb 25, 2010
    Messages:
    1,842
    Likes Received:
    18
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    You should not need to reboot the server for an issue like this; Linux processes can normally be stopped by logging into the shell and using the kill command if needed, instead of rebooting the entire server.

    Are any errors written to the cPanel error log while this is happening? Use tail -f to watch the log from the shell:

    Code:
    # tail -f /usr/local/cpanel/logs/error_log
    Use Ctrl+C to stop the tail command.

    Your description does not sound like any known common issue, so since you are able to duplicate it, I recommend that you submit a ticket so that we may log into your server and investigate this for you. It sounds like something is happening that is unique to your server's configuration and it will be hard to make any good recommendations without seeing it. Please post the ticket number so that we can follow up.
     
  4. jack01

    jack01 Well-Known Member

    Joined:
    Jul 21, 2004
    Messages:
    200
    Likes Received:
    0
    Trophy Points:
    16
    Just FYI, our issue was that the username change did not update the /var/cpanel/databases/username.yaml file with the new db user details. I manually amended the .yaml file and restarted mysql & cpanel, that fixed our problem.
     
  5. PedroR

    PedroR Registered

    Joined:
    Jan 12, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hi

    In our case it hung at some point migrating the MySQL Databases.

    I don't completely recall how we fixed it in the end.
    I'ts nice that some CPanel representative answered your post. We didn0t have that luck.

    But for the future what I recommend you to do is a /scripts/pkgacct and package the account.
    Next do a /scripts/restorepkg and pass the command line parameter to restore under a different user name (I don't recall which parameter it is).

    We're doing a migration and an upgrade between two servers that have cpanel and these two command line utils pkgacct and restorepkg became my best friends very quickly.

    There is also a nice Powerpoint/PDF presentation from Cpanel that explains very well account transfers and what these scripts do http://docs.cpanel.net/twiki/pub/Al...ources/TrainingSlides08/Account_Transfers.pdf

    Pedro.
     
Loading...

Share This Page