The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WHM installation problem -- cannot exclude openldap RPM

Discussion in 'General Discussion' started by ShirazDindar, Apr 24, 2007.

  1. ShirazDindar

    ShirazDindar Member

    Joined:
    Jan 19, 2006
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    I'm installing WHM on a fresh server according to these instructions:

    http://www.cpanel.net/docs/vps/Installation.htm

    Step 3 of the instructions reads:

    But I cannot exclude the openldap RPM because, as I read this, the dependencies on openldap have their own dependencies:

    Code:
    # rpm -qa | grep openldap
    openldap-2.3.19-4
    # rpm -e openldap-2.3.19-4
    error: Failed dependencies:
            liblber-2.3.so.0 is needed by (installed) nss_ldap-249-1.i386
            liblber-2.3.so.0 is needed by (installed) opal-2.2.1-1.i386
            liblber-2.3.so.0 is needed by (installed) cyrus-sasl-2.1.21-10.i386
            liblber-2.3.so.0 is needed by (installed) apr-util-1.2.7-1.1.i386
            liblber-2.3.so.0 is needed by (installed) samba-common-3.0.23c-1.fc5.i386
            liblber-2.3.so.0 is needed by (installed) autofs-4.1.4-33.i386
            liblber-2.3.so.0 is needed by (installed) sendmail-8.13.8-1.fc5.i386
            liblber-2.3.so.0 is needed by (installed) evolution-data-server-1.6.3-1.fc5.2.i386
            liblber-2.3.so.0 is needed by (installed) evolution-2.6.3-1.fc5.5.i386
            libldap-2.3.so.0 is needed by (installed) libuser-0.54.5-1.i386
            libldap-2.3.so.0 is needed by (installed) nss_ldap-249-1.i386
            libldap-2.3.so.0 is needed by (installed) opal-2.2.1-1.i386
            libldap-2.3.so.0 is needed by (installed) cyrus-sasl-2.1.21-10.i386
            libldap-2.3.so.0 is needed by (installed) GConf2-2.14.0-2.fc5.i386
            libldap-2.3.so.0 is needed by (installed) gnupg-1.4.6-1.i386
            libldap-2.3.so.0 is needed by (installed) apr-util-1.2.7-1.1.i386
            libldap-2.3.so.0 is needed by (installed) nfs-utils-lib-1.0.8-4.FC5.i386
            libldap-2.3.so.0 is needed by (installed) samba-common-3.0.23c-1.fc5.i386
            libldap-2.3.so.0 is needed by (installed) autofs-4.1.4-33.i386
            libldap-2.3.so.0 is needed by (installed) sendmail-8.13.8-1.fc5.i386
            libldap-2.3.so.0 is needed by (installed) evolution-data-server-1.6.3-1.fc5.2.i386
            libldap-2.3.so.0 is needed by (installed) evolution-2.6.3-1.fc5.5.i386
            libldap-2.3.so.0 is needed by (installed) cups-1.2.5-1.fc5.4.i386
            libldap-2.3.so.0 is needed by (installed) nfs-utils-1.0.8-4.fc5.i386
            libldap_r-2.3.so.0 is needed by (installed) opal-2.2.1-1.i386
            openldap is needed by (installed) nfs-utils-lib-1.0.8-4.FC5.i386
            openldap is needed by (installed) sendmail-8.13.8-1.fc5.i386
    So what should I do? Do I just leave it, continue with the installation, and trust that leaving openldap in won't interfere with Exim, as the installation instructions suggest?


    Thanks,

    Shiraz
     
  2. andren

    andren Active Member

    Joined:
    Oct 4, 2005
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    Same here, Centos 5.
     
  3. wrender

    wrender Well-Known Member

    Joined:
    Sep 29, 2007
    Messages:
    69
    Likes Received:
    3
    Trophy Points:
    8
    centos 5.1

    I am coming across the same issue with an base install of CentOS 5.1. Has anyone found a solution to this yet?
     
  4. nocbr.com

    nocbr.com Member

    Joined:
    May 1, 2006
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    same problem here. Red Hat 5.
     
Loading...

Share This Page