The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WHM is not reachable but SSH, cPanel and HTTP works just fine ..

Discussion in 'General Discussion' started by krembo99, Jun 3, 2013.

  1. krembo99

    krembo99 Member

    Joined:
    May 30, 2013
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    First of all I hope it is the right place , I am quit new to this so please excuse me if i ask the obvious ...

    I have a new server, and I Can not login to WHM. It is actually not reachable.

    My IP was blocked before by cphulk, but it was fixed. Now I get a time-out when I try to connect with port 2087 or 2086

    The server is running just fine , if I access the IP directly I see the default page and I can also access the cPanel ( I made one user before the problem started ) .Also SSH is ok and responding .

    The only problem is that I can not reach WHM ...

    Thinking it is cphulk again, I made :

    Code:
    mysql> delete from brutes;
    Query OK, 0 rows affected (0.00 sec)
    
    mysql> delete from logins;
    Query OK, 0 rows affected (0.00 sec)
    and
    Code:
     root@cpanel [~]# /usr/local/cpanel/etc/init/stopcphulkd
    I also tried to restart

    Code:
    root@cpanel [~]# service cpanel restart
    but no help .

    What can e the reason for such a behaviour ? what can I do to fix it ??
     
    #1 krembo99, Jun 3, 2013
    Last edited: Jun 3, 2013
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,811
    Likes Received:
    671
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    You can use the following command to see if cpsrvd is listening on ports 2086/2087:

    Code:
    # netstat -lnp | grep :208
    You should see a result similar to this:

    Code:
    # netstat -lnp | grep :208
    tcp        0      0 0.0.0.0:2082                0.0.0.0:*                   LISTEN      23571/cpsrvd (SSL)  
    tcp        0      0 0.0.0.0:2083                0.0.0.0:*                   LISTEN      23571/cpsrvd (SSL)  
    tcp        0      0 0.0.0.0:2086                0.0.0.0:*                   LISTEN      23571/cpsrvd (SSL)  
    tcp        0      0 0.0.0.0:2087                0.0.0.0:*                   LISTEN      23571/cpsrvd (SSL) 
    You should also check to see if you have any custom IPtables firewall rules that could be blocking access to ports 2086/2087. Or, you can check the /etc/hosts.allow file to see if any host access rules have been enabled.

    Thank you.
     
  3. krembo99

    krembo99 Member

    Joined:
    May 30, 2013
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    yep. Running your command
    Code:
    # netstat -lnp | grep :208 
    I do see an output like yours ( except I see 2349 and not 23571 )

    I have even stopped the IPtables service and flushed it , but it did not seem to help.
    I am sorry, I am very very new to all this ( 2 days ), but could you please tell me how can I check the hosts.allow file ? I mean, what should I check for ?

    using
    Code:
    vi hosts.allow
    and the same on hosts.deny - they both look empty to me (except the commented lines ..)

    can this be a DNS problem ? some wrong record ?
    The server is a fresh install with all default (except one package and Cpanel user that works fine ..)
     
    #3 krembo99, Jun 3, 2013
    Last edited: Jun 3, 2013
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,811
    Likes Received:
    671
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    The difference in the output from the netstat command is just due to a different process ID. That is normal.

    You can view those files via:

    Code:
    # cat /etc/hosts.allow
    # cat /etc/hosts.deny
    If the files are empty or only have commented entries, then it's possible there is a firewall on your local machine or ISP that is restricting your traffic. Have you tried accessing WHM from another connection to see if that's the case?

    Thank you.
     
  5. krembo99

    krembo99 Member

    Joined:
    May 30, 2013
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Thanks you you very much for following this .

    When I said that there are only the commented lines I was refering to the default lines , E.g. >

    Code:
    root@cpanel [/etc]# cat /etc/hosts.allow
    #
    # hosts.allow   This file contains access rules which are used to
    #               allow or deny connections to network services that
    #               either use the tcp_wrappers library or that have been
    #               started through a tcp_wrappers-enabled xinetd.
    #
    #               See 'man 5 hosts_options' and 'man 5 hosts_access'
    #               for information on rule syntax.
    #               See 'man tcpd' for information on tcp_wrappers
    #
    
    root@cpanel [/etc]# cat /etc/hosts.deny
    #
    # hosts.deny    This file contains access rules which are used to
    #               deny connections to network services that either use
    #               the tcp_wrappers library or that have been
    #               started through a tcp_wrappers-enabled xinetd.
    #
    #               The rules in this file can also be set up in
    #               /etc/hosts.allow with a 'deny' option instead.
    #
    #               See 'man 5 hosts_options' and 'man 5 hosts_access'
    #               for information on rule syntax.
    #               See 'man tcpd' for information on tcp_wrappers
    #
    
    Other then that those are empty ..

    As for your second suggestion, yes, I have tried to access from another machine (asked a friend from another city to do that for me ) but with no success .. also he gets timed-out ...
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,811
    Likes Received:
    671
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Do you host any domain names on this system? If so, have you tried accessing WHM using the proxy subdomains feature? EX:

    Code:
    http://whm.domain.com
    Otherwise, you are welcome to open a support ticket so we can check to see if we can access WHM, or find any reason why access is failing:

    Submit A Ticket

    If you open a ticket, please post the ticket number here so we can track the issue.

    Thank you.
     
  7. krembo99

    krembo99 Member

    Joined:
    May 30, 2013
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Thanks again ,

    Following your advice No.1 ( log with http://whm.domain.com ) yields the same result.
    Following Advice No.2 - The Request id is: 4185215
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,811
    Likes Received:
    671
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page