SOLVED WHM login Error on version 56

Virof

Registered
Sep 26, 2018
2
0
1
Malaysia
cPanel Access Level
Root Administrator
Hi,

This is Centos 6

When tried to login :

Can't locate Cpanel/Config/ConfigObj/Interface/Config/Version/v1.pm in @INC (you may need to install the Cpanel::Config::ConfigObj::Interface::Config::Version::v1 module) (@INC contains: /usr/local/cpanel /usr/local/cpanel /usr/local/cpanel/3rdparty/perl/522/lib/perl5/cpanel_lib/i386-linux-64int /usr/local/cpanel/3rdparty/perl/522/lib/perl5/cpanel_lib /usr/local/cpanel/3rdparty/perl/522/lib/perl5/5.22.1/i386-linux-64int /usr/local/cpanel/3rdparty/perl/522/lib/perl5/5.22.1 /opt/cpanel/perl5/522/site_lib/i386-linux-64int /opt/cpanel/perl5/522/site_lib) at /usr/local/cpanel/3rdparty/perl/522/lib/perl5/5.22.1/parent.pm line 20.
at /usr/local/cpanel/3rdparty/perl/522/lib/perl5/5.22.1/parent.pm line 20.
parent::import("parent", "Cpanel::Config::ConfigObj::Interface::Config::Version::v1") called at /usr/local/cpanel/Cpanel/Config/ConfigObj/Driver/LveManager/META.pm line 3
Cpanel::Config::ConfigObj::Driver::LveManager::META::BEGIN() called at /usr/local/cpanel/Cpanel/Config/ConfigObj/Driver/LveManager/META.pm line 3
eval {...} called at /usr/local/cpanel/Cpanel/Config/ConfigObj/Driver/LveManager/META.pm line 3
require Cpanel/Config/ConfigObj/Driver/LveManager/META.pm called at (eval 19) line 1
eval 'require Cpanel::Config::ConfigObj::Driver::LveManager::META; 1;' called at /usr/local/cpanel/Cpanel/Config/ConfigObj.pm line 128
Cpanel::Config::ConfigObj::get_available_drivers(undef) called at /usr/local/cpanel/Cpanel/Config/ConfigObj.pm line 245
Cpanel::Config::ConfigObj::new("Cpanel::FeatureShowcase") called at /usr/local/cpanel/Cpanel/FeatureShowcase.pm line 89
Cpanel::FeatureShowcase::new("Cpanel::FeatureShowcase") called at whostmgr/bin/whostmgr10.pl line 292
main::redirect_to_display_showcased_features("scripts3/feature_showcase") called at whostmgr/bin/whostmgr10.pl line 234
 

billchalmers

Registered
Feb 20, 2014
1
0
0
cPanel Access Level
DataCenter Provider
I had the same issue, if it helps, this is how cpanel support fixed it:

The issue here is that CloudLinux's LVE Manager is looking for a Perl module here:

/usr/local/cpanel/Cpanel/Config/ConfigObj/Interface/Config/Version/v1.pm

...however, this is a newer path to the Perl module which does not yet exist in cPanel version 11.56. The path to module on older versions of cPanel is:

/usr/local/cpanel/Cpanel/Config/ConfigObj/Interface/Config/v1.pm

I created a symlink from the old location to the new location, and WHM is now loading at the hostname URL.