James Babin

Registered
Jan 30, 2019
2
0
1
Chicago, IL
cPanel Access Level
Root Administrator
Sorry, but I could not find this anywhere. I actually did, but it just said "resovled" with no explanation.

I loaded a VM on Azure with CentOS7 and installed cPanel on it. I can access the WHM login screen, but my credentials don't work. There is no actual root login credentials in azure. I tried to "Reset" and even add a new user through the Azure Portal, but none of these work.

How do I login to WHM on an Azure based VM?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,203
363
Hi @James Babin,

The Azure instance creation interface is designed to prevent the use of root as an administrator username. You can follow the steps below to manually set the password for the root user:

1. Connect to the server via SSH using the credentials you entered for "Administrator Account" during the instance creation step in the image below:

Screen Shot 2019-01-31 at 12.56.43 AM.png

2. Enter the following command to assume the role of root:

Code:
sudo -s
3. Enter the following command to set a new password for the root user:

Code:
passwd root
You will be asked to enter the new password twice for confirmation.

4. Login to WHM as root with the password you entered in the previous step.

Let me know if this helps.

Thanks!
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,203
363
Sorry, but I could not find this anywhere. I actually did, but it just said "resovled" with no explanation.
Do you mind sharing the URL? I'd like to make sure we update that resource or thread with a valid solution.

Thank you.
 

James Babin

Registered
Jan 30, 2019
2
0
1
Chicago, IL
cPanel Access Level
Root Administrator
The thread that I found was on a different forum. I didn't find any here, but now this should be a great resource for logging into WHM/CPanel on a Microsoft Azure based VM running Centos7 or other linux operating systems when root credentials are not available. (<-- SEO!)

The steps you provided were all I needed, and everything is working great. Thank you for the quick response.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,203
363
Hello James,

I'm happy to see those steps helped. Feel free to create a new thread if you encounter any additional issues.

Thank you.