The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WHM Mail Delivery Report: Sender field source

Discussion in 'E-mail Discussions' started by swbrains, Nov 10, 2016.

  1. swbrains

    swbrains Well-Known Member

    Joined:
    Sep 13, 2006
    Messages:
    49
    Likes Received:
    2
    Trophy Points:
    158
    Hi,

    I am sending an email from a script on my server. I send it using "sendmail" and tell it (with -f) to set the FROM field to an email address @ the sending account's hosted domain to avoid DMARC policy rejections. I also set the REPLY-TO header to the "real" user's email address so replies can be directed to the actual sender's email address.

    The mail is delivered and the headers are proper as set. FROM = the @ hosted domain address and REPLY-TO is the sender's private email address.

    In WHM->Mail Delivery Report, however, the Sender column for this message shows the senders private email address instead of the hosted domain email address from the FROM header. Is this by correct?

    Also, in my customer's case, an SPF rejection occurred stating that the sender was the private email address (in the REPLY-TO header) rather than the hosted domain address used in the FROM: header (which it shows properly in the FROM: header on the bounce message). Do SPF checks normally try to verify that the REPLY-TO address is hosted on the sending server? I thought it was only supposed to check that the FROM: address resolved to the sending server.

    Thanks for any insight you can provide on either/both of these issues.

    -- Vinnie
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,171
    Likes Received:
    1,295
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Could you verify what the private email address is in this scenario? For instance, are you referring to the $username@hostname address?

    Also, in "WHM >> Exim Configuration Manager >> Basic Editor", check to see if the following options are enabled:

    "EXPERIMENTAL: Rewrite From: header to match actual sender"
    "Set SMTP Sender: headers"
    "Enable Sender Rewriting Scheme (SRS) Support"
    "Query Apache server status to determine the sender of email sent from processes running as nobody"

    Thank you.
     
Loading...

Share This Page