The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WHM, nameserver rebuild for corrupt settings?

Discussion in 'Bind / DNS / Nameserver Issues' started by mijkal, Feb 3, 2005.

  1. mijkal

    mijkal Registered

    Joined:
    Mar 11, 2003
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I've used cPanel on a reseller account for about two years now, and I finally decided to make the leap to a root WHM/cPanel setup a few days ago. The transfer was going smoothly, until a few hours ago.

    A lot of the sites are displaying totally wrong pages, either from other sites on the server or (mostly) an Apache "Hey, it worked" page (see http://www.sonicmax.com/ for example).

    My searches on Google and the cPanel forums have yielded little to fix the problem. From what I've gathered, it's a problem with a corrupt name server configuration? I've ran fixndc and fixnamed, restarted BIND and Apache each time, and nothing is working.

    Has anyone else experienced this, and more importantly, does anyone know how to fix this? Some of the posts on other forums I came across said it's a known cPanel "bug". Thanks in advance.

    -Michael Gifford
     
  2. i3903

    i3903 Well-Known Member

    Joined:
    Apr 27, 2003
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    6
    I would try rebuilding the entries in httpd.conf

    /scripts/rebuildhttpdconf >> /usr/local/apache/conf/httpd.conf

    As always backup httpd.conf before trying anything.
    When thats done, it will have rebuilt the httpd entries, restart apache and try again.
     
Loading...

Share This Page