The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WHM New Accounts Not Working

Discussion in 'General Discussion' started by sadasiva, Jun 11, 2010.

  1. sadasiva

    sadasiva Member

    Joined:
    Apr 26, 2010
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    India
    There seems to be some problem in the cPanel/WHM of our VPS.

    The problem is: New accounts are not getting created properly.

    WHM is showing account created, but it only adds the username and creates an empty directory in /home

    The dir /home/username has ownership of root:root

    Inside the dir, there is no file.

    So the cPanel for the account does not open.

    Only new acs have this problem. WHM is not able to create new accounts properly.

    We upgraded cPanel twice to Latest Stable and Latest Release, but same issue.

    cPanel error log gave:

    tail /usr/local/cpanel/logs/error_log
    ========================================================
    tar: .: Cannot change mode to rwxr-xr-x: Operation not permitted
    tar: Error exit delayed from previous errors
    edquota: Cannot set quota for user 591 from kernel on /dev/simfs: No such process
    edquota: Can't write quota for 591 on /dev/simfs: No such process
    [2010-06-11 10:24:18 +0000] warn [whostmgr5] Failed to set ownership on user directory in cpanel userdata at /usr/local/cpanel/Cpanel/Config/userdata.pm line 688
    Cpanel::Config::userdata::save_userdata('some2co', 'main', HASH(0xa8d8128)) called at /usr/local/cpanel/Cpanel/Config/userdata.pm line 723
    Cpanel::Config::userdata::save_userdata_main('some2co', HASH(0xa8d8128)) called at /usr/local/cpanel/Whostmgr/Accounts/Create.pm line 862
    Whostmgr::Accounts::Create::_wwwacct('plan', 'Bronze', 'maxpark', 0, 'hasshell', 'n', 'maxlst', 0, 'maxpop', 'n', 'maxaddon', 9, 'cpmod', 'x3', 'pass', 'dCzKbWL?Ti*=', 'force', undef, 'maxsub', 'n', 'domain', 'some2.com', 'maxsql', 'n', 'quota', 2500, 'installfp', 'y', 'maxftp', 'n', 'mxcheck', 'local', 'locale', 'en', 'contactemail', 'sadasiva2@yahoo.com', 'hascgi', 'y', 'user', 'some2co', 'useip', 'n', 'useregns', 0, 'bwlimit', 51200, 'forcedns', 0, 'owner', 'root', 'is_restore', 0, 'featurelist', 'default') called at /usr/local/cpanel/Whostmgr/Accounts/Create.pm line 1705
    Whostmgr::Accounts::Create::_createaccount('customip', '--Auto Assign--', 'plan', 'Bronze', 'language', 'en', 'maxpark', 0, 'password', 'dCzKbWL?Ti*=', 'maxlst', 0, 'maxpop', 'unlimited', 'maxaddon', 9, 'pkgname', '', 'cpmod', 'x3', 'cgi', 1, 'maxsub', 'unlimited', 'domain', 'some2.com', 'maxsql', 'unlimited', 'hasuseregns', 1, 'sign', '', 'quota', 2500, 'mxcheck', 'local', 'maxftp', 'unlimited', 'contactemail', 'sadasiva2@yahoo.com', 'username', 'some2co', 'frontpage', 1, 'bwlimit', 51200, 'featurelist', 'default') called at whostmgr/bin/whostmgr5 line 629
    main::wwwacct() called at whostmgr/bin/whostmgr5 line 210
    ========================================================
     
  2. blazenetworks

    blazenetworks Member

    Joined:
    May 21, 2009
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    HI

    I am also facing the same problem.WHM new accounts are not working properly.I dont know its happened to us or for all.Could somebody help us what should be done?:confused:
     
  3. sadasiva

    sadasiva Member

    Joined:
    Apr 26, 2010
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    India

    No no its not a prob with cPanel. It was my VPS, whose QUOTAUGIDLIMIT (second level quota limit), which had exhausted. I complained the VPS Provider and they increased it. Everything workings perfect now.

    Get it increased and run /scripts/fixquotas

    All works normal.
     
Loading...

Share This Page