The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WHM partially encrypted

Discussion in 'Security' started by PPNSteve, Aug 29, 2012.

  1. PPNSteve

    PPNSteve Well-Known Member

    Joined:
    Mar 13, 2003
    Messages:
    393
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Somewhere in Ilex Forest
    cPanel Access Level:
    Root Administrator
    Twitter:
    We have a few servers running cPanel/WHM with a SSL issue. it appears as some content in WHM is only partially encrypted on 2 of them, thus not giving us a fully secure management interface.

    These server uses real certs from geotrust and not the self-signed ones that are standard/included )one uses self-signed without this problem).

    my question is, how to we force / fix it so all the cPanel and WHM https data flow is encrypted properly?
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    I've never seen a case where Web Host Manager did not load encrypted content when using the secure URL. Could you submit a support ticket so we can take a closer look?

    Submit A Ticket

    You can post the ticket number here so we can track the issue.

    Thank you.
     
  3. PPNSteve

    PPNSteve Well-Known Member

    Joined:
    Mar 13, 2003
    Messages:
    393
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Somewhere in Ilex Forest
    cPanel Access Level:
    Root Administrator
    Twitter:
    Support ticket submitted, Your Request id is: 3114503

    I have 3 servers up currently and all run the same build of cPanel/WHM and only one doesn't have this SSL problem.

    Thanks in advance.

    [EDIT:] strange.. I've loaded and loaded WHM many times over the last few months with this problem and a hard refresh (ctrl+F5) just cleared the partial encryption.

    VERY strange.

    You still may want to take a look to see why it was loading as partially encrypted.
     
    #3 PPNSteve, Sep 1, 2012
    Last edited: Sep 1, 2012
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    There's no way to determine why it occurred in the past if refreshing shows no issue any longer. We'd need to be able to replicate the issue to troubleshoot it.

    The main reason a site loads as only partially encrypted would occur when some content is trying to load via http versus https. WHM doesn't have any hard links to http so it couldn't be loading partially encrypted. Now, if a plugin or icon were installed that weren't set to properly use https when coming on via the secure like, then that plugin or icon might cause WHM to show partial encryption. That would be an issue with the provider of the plugin or whatever was added to WHM from a third party source.
     
Loading...

Share This Page