The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WHM php not working

Discussion in 'General Discussion' started by whitewlf, Mar 30, 2007.

  1. whitewlf

    whitewlf Member

    Joined:
    Jan 14, 2006
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    I only noticed this on Fantastico, as nothing else is php as far as I know... After trying allt he fixes at the Fantastico site, however, it is removed/uninstalled and will not reinstall due to WHM not parsing php. in view-fram-source I see the bare php-redirect , and even tried add php commands which went un parsed.

    Strange thing is, until I fully uninstalled fantastico, it -worked- in user's cpanel/ sites... meaning php was working on /cpanel/ but not /whm/. I even created a simple <php print "Test"; ?> page in the addons for WHM, it produced the same source, php visible unparsed.

    Now I cannot get fantastico to install as it needs php to do so. I have tried makecpphp --force, upgrading the server, cpanel, etc. It's been like this for months and months. I've asked others to help to no avail, they say "Oh, just reinstall cpanel.." or "Fresh install cpanel."...

    oooo great idea... destroy every user account, take the site down for a couple days while my webhosting co (it is a dedicated server 6000miles away from me) reinstalls it, and I spend the next 2-5 days trying to reconstruct all the accounts. And, no.. backing them up does not seem 100% effective, sites break.

    I have configserver do a full hardening/mail/etc install on it once.. when it was done, the problem went away. A couple cpanel updates later, it was back. I've contacted configserver a couple times, and they have no idea why it got fixed, or why it broke again.

    Note: makecpphp --force generates this error, but completes:



    Build complete.
    (It is safe to ignore warnings about tempnam and tmpnam).

    Installing PHP SAPI module: cgi
    Installing PHP CGI into: /usr/local/cpanel/3rdparty/bin/
    Installing PEAR environment: /usr/local/cpanel/3rdparty/lib/php/
    [PEAR] Archive_Tar: bad md5sum for file /usr/local/cpanel/3rdparty/lib/php/Archive/Tar.php
    [PEAR] Console_Getopt - already installed: 1.2
    [PEAR] HTML_Template_IT- already installed: 1.1
    [PEAR] Net_UserAgent_Detect- already installed: 2.0.1
    pear/PEAR dependency package "pear/Archive_Tar" installed version 1.1 is not the recommended version 1.3.1, but may be compatible, use --force to install
    pear/PEAR requires package "pear/XML_RPC" (version >= 1.4.0), installed version is 1.3.3

    Notice: Only variables should be assigned by reference in /home/cpphpbuild/php-4.4.2/pear/PEAR/Installer.php on line 982
    [PEAR] PEAR: Installation failed: invalid package file
    Installing build environment: /usr/local/cpanel/3rdparty/lib/php/build/
    Installing header files: /usr/local/cpanel/3rdparty/include/php/
    Installing helper programs: /usr/local/cpanel/3rdparty/bin/
    program: phpize
    program: php-config
    Installing man pages: /usr/local/cpanel/3rdparty/man/man1/
    page: phpize.1
    page: php-config.1
    PHP version file is up to date


    I deleted the php files from /home/cpphpbuild/ which made no difference. Searching shows that php 4.4.2, used by cpanel spserv, is a broken release for pear.


    This is what I see in source from the WHM fantastico addon.

    <?php
    //----------------------------------------------------------------------------//
    header ( "Location: fantastico.php" ) ;
    //----------------------------------------------------------------------------//
    ?>


    Mailwatch from ConfigServer Mailscanner FE is the only other item not working on the cpanel install, that I know of... Though, trying to make Interchange install was giving me problems once, I have not tried since.

    And yes, I restarted the cpserv services and rebooted the server as well. Nothing helps.

    WHM 10.8.0 cPanel 10.9.0-C8800
    CentOS 4.4 i686 - WHM X v3.1.0
    Hosting Co: Serverbeach, San Antonio
    Dell Poweredge 430-2, 2G


    EDIT:

    phpmyadmin, which also uses php from the WHM/cpserv, is a separate window even, produces no output. Mailwatch, via MailscannerFE is the same. I cannot find any errors/logs/etc as to why, nor find anywhere to "Turn on/off" php parsing/processing for WHM.
     
    #1 whitewlf, Mar 30, 2007
    Last edited: Mar 31, 2007
  2. whitewlf

    whitewlf Member

    Joined:
    Jan 14, 2006
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Still making no headway

    Checked again.. If I try to even open a standard html file <html> Test </html> I get blank pages and no output form WHM via the 3rdparty location, which is where mailwatch and phpmyadmin are served from.

    The logs say I am accessing the pages, etc.. but there is nothing, not even in source... Blank pages. If I try to access a page that does not exist, I get an error.. Though no errors at all are in the logs... /usr/local/cpanel/logs/error_log is dead empty. It only registers pages that DO NOT exist in access_log, actually.. trying to access the existing pages (blank) generate no log of anykind. below I tried the existing /phpMyAdmin/ urls in between the ones below.

    XX.XX.231.153 - wolfnet [01/Apr/2007:05:49:44 -0400] "GET /3rdparty/test2dd.html HTTP/1.1" 404 0 "" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3"
    127.0.0.1 - [01/Apr/2007:05:55:45 -0400] "GET / HTTP/1." 401 0 "" ""
    127.0.0.1 - [01/Apr/2007:06:04:10 -0400] "GET / HTTP/1." 401 0 "" ""
    127.0.0.1 - [01/Apr/2007:06:12:35 -0400] "GET / HTTP/1." 401 0 "" ""
    - [01/Apr/2007:06:15:22 -0400] "" 500 0 "" ""
    - [01/Apr/2007:06:15:23 -0400] "" 500 0 "" ""
    - [01/Apr/2007:06:15:35 -0400] "" 500 0 "" ""
    - [01/Apr/2007:06:15:41 -0400] "" 500 0 "" ""
    127.0.0.1 - [01/Apr/2007:06:21:00 -0400] "GET / HTTP/1." 401 0 "" ""
    XX.XX.231.153 - wolfnet [01/Apr/2007:06:25:54 -0400] "GET /3rdparty/phpmydorkus HTTP/1.1" 404 0 "" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3"
    XX.XX.231.153 - wolfnet [01/Apr/2007:06:26:14 -0400] "GET /3rdparty/phpMyAdmin/index.html HTTP/1.1" 404 0 "" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3"
     
Loading...

Share This Page