Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

WHM php4/php5

Discussion in 'General Discussion' started by vijeesh, Jun 22, 2008.

  1. vijeesh

    vijeesh Member

    Joined:
    May 26, 2006
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    151
    Hello,

    I have recomipled Apache with both php5 (DSO) and php4 (cgi) enabled.
    When i run .php4 scripts , getting the following error


    Warning: Unexpected character in input: '' (ASCII=15) state=1 in /usr/local/cpanel/cgi-sys/php4 on line 3799

    Warning: Unexpected character in input: '' (ASCII=2) state=1 in /usr/local/cpanel/cgi-sys/php4 on line 3799

    Warning: Unexpected character in input: ' in /usr/local/cpanel/cgi-sys/php4 on line 3799

    Any idea?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. Webfreak

    Webfreak Registered

    Joined:
    Nov 21, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    151
    Location:
    Uitenhage, Eastern Cape, South-Africa
    This is the fix for php4 error

    This worked for me.

    EDIT your php.ini file:
    In /usr/local/php4/lib/php.ini

    Under
    ;;;;;;;;;;;;;;;;;;;;;;;;;
    ; Paths and Directories ;
    ;;;;;;;;;;;;;;;;;;;;;;;;;

    UNCOMMENT this line
    Code:
    ;cgi.fix_pathinfo=0
    (i.e. remove the ";" infront)

    and

    CHANGE 0 to 1:
    Code:
    cgi.fix_pathinfo=1
    Save and that's it. Instant fix!

    See: http://forums.cpanel.net/showthread.php?p=399697

    Thanks...
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice