The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WHM site from shared to dedicated IP shows default "Great Success! Apache is working"

Discussion in 'EasyApache' started by g18c, Aug 29, 2009.

  1. g18c

    g18c Member

    Joined:
    Jul 7, 2007
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    Hi, I am having some strange issues when i change my site IP to a dedicated address, on the dedicated address it shows the 'unbound' site which says "Great Success! Apache is working on your cPanel server".

    When the site is on the shared ip of the main server it is fine. All the following sites are accesbile:
    Code:
    http://mydomain.me -> OK
    http://www.mydomain.me -> OK
    http://support.mydomain.me -> OK
    The config (this hasnt been modified, straight 'cat /usr/local/apache/conf/httpd.conf') is below:

    Code:
    NameVirtualHost 88.11.11.54:80
    <VirtualHost 87.31.21.54:80>
        ServerName mydomain.me
        ServerAlias www.mydomain.me
        DocumentRoot /home/mydomain/public_html
        ServerAdmin webmaster@mydomain.me
        ## User mydomain # Needed for Cpanel::ApacheConf
        <IfModule mod_suphp.c>
            suPHP_UserGroup mydomain mydomain
        </IfModule>
        <IfModule !mod_disable_suexec.c>
            SuexecUserGroup mydomain mydomain
        </IfModule>
        CustomLog /usr/local/apache/domlogs/mydomain.me-bytes_log "%{%s}t %I .\n%{%s}t %O ."
        CustomLog /usr/local/apache/domlogs/mydomain.me combined
        Options -ExecCGI -Includes
        RemoveHandler cgi-script .cgi .pl .plx .ppl .perl
        ScriptAlias /cgi-bin/ /home/mydomain/public_html/cgi-bin/
        # To customize this VirtualHost use an include file at the following location
        # Include "/usr/local/apache/conf/userdata/mydomain/mydomain.me/*.conf"
    </VirtualHost>
    
    NameVirtualHost 88.11.11.54:80
    <VirtualHost 87.31.21.54:80>
        ServerName support.mydomain.me
        ServerAlias www.support.mydomain.me
        DocumentRoot /home/mydomain/public_html/support
        ServerAdmin webmaster@support.mydomain.me
        ## User mydomain # Needed for Cpanel::ApacheConf
        <IfModule mod_suphp.c>
            suPHP_UserGroup mydomain mydomain
        </IfModule>
        <IfModule !mod_disable_suexec.c>
            SuexecUserGroup mydomain mydomain
        </IfModule>
        CustomLog /usr/local/apache/domlogs/support.mydomain.me-bytes_log "%{%s}t %I .\n%{%s}t %O ."
        CustomLog /usr/local/apache/domlogs/support.mydomain.me combined
        Options -ExecCGI -Includes
        RemoveHandler cgi-script .cgi .pl .plx .ppl .perl
        ScriptAlias /cgi-bin/ /home/mydomain/public_html/support/cgi-bin/
        # To customize this VirtualHost use an include file at the following location
        # Include "/usr/local/apache/conf/userdata/mydomain/support.mydomain.me/*.conf"
    </VirtualHost>
    
    <VirtualHost 87.31.21.54:80>
        ServerName myotherdomain.com
        ServerAlias www.myotherdomain.com
        DocumentRoot /home/sysdrsc/public_html
        ServerAdmin webmaster@myotherdomain.com
        ## User sysdrsc # Needed for Cpanel::ApacheConf
        <IfModule mod_suphp.c>
            suPHP_UserGroup sysdrsc sysdrsc
        </IfModule>
        <IfModule !mod_disable_suexec.c>
            SuexecUserGroup sysdrsc sysdrsc
        </IfModule>
        CustomLog /usr/local/apache/domlogs/myotherdomain.com-bytes_log "%{%s}t %I .\n%{%s}t %O ."
        CustomLog /usr/local/apache/domlogs/myotherdomain.com combined
        Options -ExecCGI -Includes
        RemoveHandler cgi-script .cgi .pl .plx .ppl .perl
        ScriptAlias /cgi-bin/ /home/sysdrsc/public_html/cgi-bin/
    </VirtualHost>
    I then change the site IP in WHM to the dedicated address:
    Code:
    Changed all instances of [87.31.21.54] -> [88.11.11.54] in mydomain.me
    Updating httpd.conf....Done
    Bind reloading on cartman using rndc
    Bind reloading on stan using rndc
    
    System has 0 free ips.
    I checked DNS and the dns entries point to the new IP which is fine.

    However when trying to browse the site again i get the unbound holding page come up:
    Code:
    http://mydomain.me -> Great Success! Apache is working on your cPanel server
    http://www.mydomain.me -> Great Success! Apache is working on your cPanel server
    http://support.mydomain.me -> Great Success! Apache is working on your cPanel server
    http://www.support.mydomain.me -> OK
    The only site that works correctly is when the following URL is used: http://www.support.mydomain.me, however this is not what i want, i literally want to access the site from http://support.mydomain.me as is working properly on the shared IP.

    The config ('cat /usr/local/apache/conf/httpd.conf') after the site IP change is below:
    Code:
    NameVirtualHost 88.11.11.54:80
    <VirtualHost 88.11.11.54:80>
        ServerName mydomain.me
        ServerAlias www.mydomain.me
        DocumentRoot /home/mydomain/public_html
        ServerAdmin webmaster@mydomain.me
        ## User mydomain # Needed for Cpanel::ApacheConf
        <IfModule mod_suphp.c>
            suPHP_UserGroup mydomain mydomain
        </IfModule>
        <IfModule !mod_disable_suexec.c>
            SuexecUserGroup mydomain mydomain
        </IfModule>
        CustomLog /usr/local/apache/domlogs/mydomain.me-bytes_log "%{%s}t %I .\n%{%s}t %O ."
        CustomLog /usr/local/apache/domlogs/mydomain.me combined
        Options -ExecCGI -Includes
        RemoveHandler cgi-script .cgi .pl .plx .ppl .perl
        ScriptAlias /cgi-bin/ /home/mydomain/public_html/cgi-bin/
        # To customize this VirtualHost use an include file at the following location
        # Include "/usr/local/apache/conf/userdata/mydomain/mydomain.me/*.conf"
    </VirtualHost>
    
    NameVirtualHost 88.11.11.54:80
    <VirtualHost 88.11.11.54:80>
        ServerName support.mydomain.me
        ServerAlias www.support.mydomain.me
        DocumentRoot /home/mydomain/public_html/support
        ServerAdmin webmaster@support.mydomain.me
        ## User mydomain # Needed for Cpanel::ApacheConf
        <IfModule mod_suphp.c>
            suPHP_UserGroup mydomain mydomain
        </IfModule>
        <IfModule !mod_disable_suexec.c>
            SuexecUserGroup mydomain mydomain
        </IfModule>
        CustomLog /usr/local/apache/domlogs/support.mydomain.me-bytes_log "%{%s}t %I .\n%{%s}t %O ."
        CustomLog /usr/local/apache/domlogs/support.mydomain.me combined
        Options -ExecCGI -Includes
        RemoveHandler cgi-script .cgi .pl .plx .ppl .perl
        ScriptAlias /cgi-bin/ /home/mydomain/public_html/support/cgi-bin/
        # To customize this VirtualHost use an include file at the following location
        # Include "/usr/local/apache/conf/userdata/mydomain/support.mydomain.me/*.conf"
    </VirtualHost>
    
    
    <VirtualHost 87.31.21.54:80>
        ServerName myotherdomain.com
        ServerAlias www.myotherdomain.com
        DocumentRoot /home/sysdrsc/public_html
        ServerAdmin webmaster@myotherdomain.com
        ## User sysdrsc # Needed for Cpanel::ApacheConf
        <IfModule mod_suphp.c>
            suPHP_UserGroup sysdrsc sysdrsc
        </IfModule>
        <IfModule !mod_disable_suexec.c>
            SuexecUserGroup sysdrsc sysdrsc
        </IfModule>
        CustomLog /usr/local/apache/domlogs/myotherdomain.com-bytes_log "%{%s}t %I .\n%{%s}t %O ."
        CustomLog /usr/local/apache/domlogs/myotherdomain.com combined
        Options -ExecCGI -Includes
        RemoveHandler cgi-script .cgi .pl .plx .ppl .perl
        ScriptAlias /cgi-bin/ /home/sysdrsc/public_html/cgi-bin/
    </VirtualHost>
    Would greatly appreciate points as to what might be going on here. In summary i have the following questions:

    1) Does anyone know why in the original config when the mydomain.me site is on the shared ip (87.31.21.54) does the NameVirtualHost 88.11.11.54:80 appear? On the other sites hosted on the shared IP for the server there is no such directive (myotherdomain.com does not have this, please see above configs)?

    2) Is it worth deleting the account and recreating it?

    3) I am moving the site to a dedicated IP because WHM wouldnt let me install a cert i purchased from godaddy for the address support.mydomain.me whilst on the shared address. WHM insisted i assign a dedicated IP which led to the fun and games above :). Are dedicated IPs required for all certs? I couldnt see this requirment with godaddy.

    Either way it doesnt matter, i have the IP i just want to get cPanel working with it!!

    Many thanks in advance,

    Chris
     
  2. MattCurry

    MattCurry Well-Known Member

    Joined:
    Aug 18, 2009
    Messages:
    275
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Houston, Tx
    Hello,

    Just looking over the data it looks like it should be good. However, I would recommend putting in a ticket so we can take a closer look at this issue. Please let me know if you have any other questions.

    Thank you,
    Matthew Curry
     
  3. jsnape

    jsnape Well-Known Member

    Joined:
    Mar 11, 2002
    Messages:
    174
    Likes Received:
    0
    Trophy Points:
    16
    Most likely because your ISP cached the old IP. If you ping the name and it pings to the old IP, that is what is happening. It'll resolve itself. Time heals all wounds. :D
     
  4. MSITHero

    MSITHero Registered

    Joined:
    Aug 26, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    That does not help the rest of us with the same issue. I have seen this before on cpanel. When I take a website from shared ip to dedicated it does this. It works just fine if I point to the ip address I want but if I use the domain name I get the Great Success! page. I am running into this issue now again. This is very frustrating.
     
  5. landman

    landman Member

    Joined:
    Sep 15, 2009
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    i am having much the same issues as this chap, I am testing a cpanel server on my local network

    Ok here goes for my issue.

    when i use this setting in my httpd.conf

    Code:
    <VirtualHost 192.168.96.3:80>
        ServerName site.info
        ServerAlias www.site.info
        DocumentRoot /home/site/public_html
        ServerAdmin webmaster@site.info
        UseCanonicalName Off
        CustomLog /usr/local/apache/domlogs/site.info combined
        CustomLog /usr/local/apache/domlogs/site.info-bytes_log "%{%s}t %I .\n%{%s}t %O ."
        ## User prostate # Needed for Cpanel::ApacheConf
        <IfModule !mod_disable_suexec.c>
            SuexecUserGroup site site
        </IfModule>
        ScriptAlias /cgi-bin/ /home/site/public_html/cgi-bin/
    
    
        # To customize this VirtualHost use an include file at the following location
        # Include "/usr/local/apache/conf/userdata/std/2/site/site.info/*.conf"
    
    </VirtualHost>
    All works just fine and i see the website, But if i change the local ip on the Virtual host from the above to the below.

    Code:
    <VirtualHost 212.158.102.47:80>
        ServerName site.info
        ServerAlias www.site.info
        DocumentRoot /home/site/public_html
        ServerAdmin webmaster@site.info
        UseCanonicalName Off
        CustomLog /usr/local/apache/domlogs/site.info combined
        CustomLog /usr/local/apache/domlogs/site.info-bytes_log "%{%s}t %I .\n%{%s}t %O ."
        ## User prostate # Needed for Cpanel::ApacheConf
        <IfModule !mod_disable_suexec.c>
            SuexecUserGroup site site
        </IfModule>
        ScriptAlias /cgi-bin/ /home/site/public_html/cgi-bin/
    
    
        # To customize this VirtualHost use an include file at the following location
        # Include "/usr/local/apache/conf/userdata/std/2/site/site.info/*.conf"
    
    </VirtualHost>
    When i visit "www.site.com" in the web browser and any related subdomain to the domain i see the following message.

    Code:
    Great Success !
    Apache is working on your cPanel® and WHM™ Server
    
    If you can see this page, then the people who manage this server have installed cPanel and WebHost Manager (WHM) which use the Apache Web server software and the Apache Interface to OpenSSL (mod_ssl) successfully. They now have to add content to this directory and replace this placeholder page, or else point the server at their real content.
    ATTENTION!
    
    If you are seeing this page instead of the site you expected, please contact the administrator of the site involved. (Try sending an email to <webmaster@domain>.) Although this site is running cPanel, WebHost Manager, and Apache software it almost certainly has no other connection to cPanel Inc. or the Apache Group. Please do not send mail about this site or its contents to cPanel Inc. or the Apache Group.
    About cPanel:
    
    cPanel is a leading provider of software for the webhosting industry. If you would like to learn more about cPanel please visit our website at www.cpanel.net. Please be advised that cPanel Inc. is not a web hosting company, and as such has no control over content found elsewhere on this site.
    About Apache HTTP Server:
    
    The Apache HTTP Server is an open source web server which powers many of the worlds web sites. The Apache HTTP server is part of the Apache Group's many influential projects. Their efforts have helped shape much the world wide web, and they continue to be a dominating force in the web hosting industry.
    And not that of the intended web directory, Now i have made sure the DNS server had the same IP as in the "httpd.conf" and i restarted both after the changes and i waited for DNS to properly probigate. But still nothing i get the same message.

    Can anyone help me as its starting to tick me off. I have raised a support ticket https://tickets.cpanel.net/review/msg.cgi?ticketid=492938 so if your a member of cpanel support you can reply there if you wish.

    Thanks in advance for your help.

    Warmest Regards
    Dean
     
  6. cPanelGregK

    cPanelGregK Administrator
    Staff Member

    Joined:
    Sep 8, 2006
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Dean,

    Your ticket has been received, and I'm looking into it now. We should have resolution to this issue shortly.
     
Loading...

Share This Page