Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

WHM : upgrade to Apache 2.0.64

Discussion in 'EasyApache' started by ieche, Jan 31, 2011.

  1. ieche

    ieche Registered

    Joined:
    Jan 31, 2011
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    51
    Hi,

    I am using WHM 11.28.64 on CENTOS 5.5 X86_64 standard

    Apache current version is 2.0.63 and I want to update it to 2.0.64

    When using EasyApache (Main >> Software >> EasyApache (Apache Update) ) I can't choose the apache 2.0 versions (I can choose several versions of PHP4 & PHP5).

    what appears is : Apache 1.3 * Apache 2.0 & Apache 2.2

    So, how can I update apache from 2.0.63 to 2.0.64?
     
  2. LinuxTechie

    LinuxTechie Well-Known Member

    Joined:
    Jan 22, 2011
    Messages:
    502
    Likes Received:
    5
    Trophy Points:
    68
    cPanel Access Level:
    Root Administrator
    Hello,

    Easyapache does not have the version 2.0.64. If you choose Apache 2.0 it will result in 2.0.63 only. I don't thinks there is a major difference b/w the two versions? Can't you upgrade it to Apache 2.2 instead?

    You can always manually upgrade apache to the version you wants!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,608
    Likes Received:
    32
    Trophy Points:
    238
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Hello steveausten,

    I did want to mention that you can see the latest available versions of Apache, EasyApache and PHP if you run the following in root SSH:

    Code:
    /scripts/easyapache --latest-versions
    You'd get a return like the following when using that command:

    Code:
    Easy::Apache v3.2.0 Build 5291
    
    [Apache]
    	1.3.42, 2.0.63, 2.2.17
    
    [PHP 4]
    	4.4.6, 4.4.7, 4.4.8, 4.4.9
    
    [PHP 5]
    	5.2.9, 5.2.16, 5.3.3, 5.3.4
    You can see your current Apache, cPanel and PHP versions using this command:

    Code:
    /scripts/easyapache --version
    Where you'd see something like the following:

    Code:
    Easy::Apache v3.2.0 Build 5291
    
    [cpanel]
    11.28.75-EDGE_51144
    
    
    [apache]
    Server version: Apache/2.2.16 (Unix)
    Server built:   Nov  4 2010 16:30:31
    Cpanel::Easy::Apache v3.2.0 rev5210
    
    
    [server]
    Linux server.domain. 2.6.9-89.0.25.EL #1 Thu May 6 12:17:11 EDT 2010 i686 i686 i386 GNU/Linux
    You can also do this in WHM > EasyApache (Apache Update) area by clicking on [Help] > [Report version info of ea3, cpanel, and apache] (to see the currently existing versions) or [Help] > [List latest version of Apache, PHP, etc that this installs] (to see the latest available versions)

    Thanks.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. LinuxTechie

    LinuxTechie Well-Known Member

    Joined:
    Jan 22, 2011
    Messages:
    502
    Likes Received:
    5
    Trophy Points:
    68
    cPanel Access Level:
    Root Administrator
    Hello Tristan,

    Thanks for the new commands!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. ieche

    ieche Registered

    Joined:
    Jan 31, 2011
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    51
    thanks for the replay

    according to this site :

    Tenable Network Security

    there are sevearl secutry issuse with 2.0.63

    ==

    cPanelTristan

    thanks for the replay,

    but EasyApache dosn't show the latest available versions of Apache 2.0.64

    Apache HTTP Server Project
     
  6. LinuxTechie

    LinuxTechie Well-Known Member

    Joined:
    Jan 22, 2011
    Messages:
    502
    Likes Received:
    5
    Trophy Points:
    68
    cPanel Access Level:
    Root Administrator
    Hello,

    Thanks for informing us about those vulnerabilities in Apache 2.0.63. As easy apache does not have the specified version can't you upgrade it to Apache 2.2?

    Thanks
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,608
    Likes Received:
    32
    Trophy Points:
    238
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    I didn't state it was the latest Apache version, but the latest version available. Thus, the latest version we have available via EasyApache.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice