The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WHM using wrong named.conf file.

Discussion in 'General Discussion' started by Necroist, Jul 26, 2004.

  1. Necroist

    Necroist Active Member

    Joined:
    Jul 21, 2004
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    Hi, WHM has been acting weird.

    How can I make WHM use /etc/namedb/named.conf instead of /etc/named.conf?

    Right now, WHM writes all zones to /etc/named.conf, but restarts bind at /etc/namedb/named.conf

    Because of that I'm having alot of problems, does anyone have a solution for this problem?
     
  2. Necroist

    Necroist Active Member

    Joined:
    Jul 21, 2004
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    anybody at all?
     
  3. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    Wouldn't it be easier to change where it restarts bind?
     
  4. Necroist

    Necroist Active Member

    Joined:
    Jul 21, 2004
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    What do you mean?
     
  5. sjackson909

    sjackson909 Well-Known Member

    Joined:
    Jun 8, 2004
    Messages:
    113
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Columbus, OH
    mv /etc/named.conf /etc/named.conf.old
    ln -s /etc/namedb/named.conf /etc/named.conf

    That will fix it. I would really just change it where named starts like casey said :)
     
  6. Necroist

    Necroist Active Member

    Joined:
    Jul 21, 2004
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    I really don't get what you mean by

    "change it where named starts"
     
  7. sjackson909

    sjackson909 Well-Known Member

    Joined:
    Jun 8, 2004
    Messages:
    113
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Columbus, OH
    When you server boots up init will run a script that will start named. I'm guess your running linux so I think it would be in your /etc/init.d/ dir. I'm BSD guy so in FB its just in your /etc/rc.conf file.
     
  8. Necroist

    Necroist Active Member

    Joined:
    Jul 21, 2004
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    GOSH!

    Thanks! I've been trying to find out how to do that, thanks!

    Works perfectly, now whenever I restart bind, it uses /etc/named.conf instead of /etc/namedb/named.conf.

    Unfortunately, I'm still having problems with the DNS. So I've deleted one of my accounts (markngan.net), checked the named.conf and I don't find any traces of it.

    Then I restarted bind, flushed my dns on my PC and I'm still able to see (markngan.net) pointing to my server and its loading the site of the last client account that was created in WHM.

    Again, thanks alot with the rc.conf. I think you guys might had saved me from reformating.

    P/S: I realised that if I type in my ip address in my browser's URL address bar, I don't get pointed to /home/www (my DocumentRoot in Apache) but instead the last created acct.

    So I guess there's another new problem now :(
     
    #8 Necroist, Jul 27, 2004
    Last edited: Jul 27, 2004
  9. Necroist

    Necroist Active Member

    Joined:
    Jul 21, 2004
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    anyone?

    thanks again.
     
  10. bamasbest

    bamasbest Well-Known Member

    Joined:
    Jan 10, 2004
    Messages:
    531
    Likes Received:
    0
    Trophy Points:
    16
    Accessing accounts via IP address when they are shared, will normally result with the first entry in httpd.conf being served up for that IP. Just an http 1.1 issue, but you can be thankful that multiple accounts can use a shared IP addy as opposed to having to pay for a dedicated IP for every account.

    If you need to see your account online, you could access via http://your.host.com/~username/ if you allow the tilde option.
     
  11. Necroist

    Necroist Active Member

    Joined:
    Jul 21, 2004
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    But shouldn't apache serve up the documentroot specified in the httpd.conf?
     
  12. Necroist

    Necroist Active Member

    Joined:
    Jul 21, 2004
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    anyone at all?
     
  13. sjackson909

    sjackson909 Well-Known Member

    Joined:
    Jun 8, 2004
    Messages:
    113
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Columbus, OH
    Yes, but it sounds like you have a shared IP on your server. So it doesn't know which one to pull up.

    Like bamasbest said. apache should pull up the first documentroot in the httpd.conf.
     
Loading...

Share This Page