SOLVED WHM won't load but SSH/Cpanel/WWW all work

Mikeyc

Registered
Mar 21, 2017
3
1
3
USA
cPanel Access Level
Root Administrator
Been a cPanel user for a long time but just installed an instance in Azure. Having some trouble getting things to work properly.

Yesterday it seemed I got locked out because of cphulk, getting spammed root attempts. Tried following some documentation to disable cphulk and later in the day things were working.

Now since yesterday I've had the issue that my samples sites are loading fine when visiting from both http/https. I can visit my site's cPanel login fine, server.mydomain.com/cpanel will bring me there. However when I try to visit server.mydomain.com/whm it just spins and doesn't respond. Telnet also doesn't have luck on the 2087 or 2086 ports.

I still have cphulk disabled and not sure where else to look. Tried flushing iptables, still not loading. Any suggestions? Thanks everyone!
 

Mikeyc

Registered
Mar 21, 2017
3
1
3
USA
cPanel Access Level
Root Administrator
I noticed that from SSH I can use Lynx and it loads up the localhost/whm. In Azure there is a built in network firewall that was working fine before this issue started, to help remove that from the equation I temporarily opened up all ports within there, nothing is still working externally.

Any ideas if this is a local firewall issue? Aside from flushing iptables or stopping firewalld I am not sure what else to try.
 

Mikeyc

Registered
Mar 21, 2017
3
1
3
USA
cPanel Access Level
Root Administrator
I kept digging into iptables and firewalld. Eventually found that I had to issue the command 'systemctl start firewalld' to restart the firewalld service and now I can access WHM externally again!
 
  • Like
Reactions: cPanelMichael

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,226
463
Hello,

I'm happy to see the issue is now addressed. Thank you for updating us with the outcome.