wdwms

Member
Jan 31, 2005
16
0
151
Trying to move from 4.4.2 to 4.4.4, and rebuilding apache from easyapache or through WHM just leaves PHP at 4.4.2. I'm selecting 4.4.4 in the options after I load the previous config, but no go.. any ideas on how to force this?

Thanks
-t
 

mohit

Well-Known Member
Jul 12, 2005
553
0
166
Sticky On Internet
have you restarted httpd

hi,
have you tried restarting httpd couple of times after re-building ?

see ya,
mohit
 

Spiral

BANNED
Jun 24, 2005
2,020
8
193
This goes down as a "no brainer" but should probably be mentioned anyway .....

Did you remember to clear your web browser cache?

Assuming you compiled everything correctly and remembered to restart apache
after the compile, you are probably running on the new PHP but it won't show up
if you are trying to tell what version you are running by any web page display
such as a page with "phpinfo();" because the old screen will be cached so it
is always a good idea to clear your web browser cache.

Now with that said, Cpanel is lousy about doing sanity checks so if the PHP compile
fails for any reason, I noticed that EasyApache will still continue on like it worked.

I personally recommend just forgetting about the PHP options in EasyApache and
leave it set to whatever --- doesn't really matter --- and then just manually compile
your own PHP which is rediculously simple to do.

1. Download and unpack the source from www.php.net

2. Open a page with phpinfo(); and copy the "./configure" line from that screen

3. Run the configure line from the directory where you placed the PHP source code

4. Run "make"

5. Run "make test"

6. Run "make install"

Thats pretty much it! You can customize the PHP options however you wish but the
options from your previous PHP installation will usually work just fine.
 

wdwms

Member
Jan 31, 2005
16
0
151
I ran easy apache for the 4th time and whaddya know.. it built it.. so it upgraded to 1.3.37, and php 4.4.4, but funny thing is, all cpanel intalls say 1.3.34.. httpd -v returns 1.3.37, but WHM never updated _usr_local_apache_bin_httpd_ file

odd...