CubeSyVal

Registered
Jun 12, 2019
2
0
1
Australia
cPanel Access Level
DataCenter Provider
Hi All,

I'm trying to run whmapi1 php_get_vhost_versions on my server (v76.0.22) and it only displays this error

# whmapi1 php_get_vhost_versions
---
data:
versions: []

metadata:
command: php_get_vhost_versions
reason: OK
result: 1
version: 1
On other servers I have this command works fine, I just want to get a list of php versions for each account

Thanks
 

cPanelLauren

Forums Analyst II
Staff member
Nov 14, 2017
6,762
535
263
Houston
cPanel Access Level
DataCenter Provider
This isn't actually an error it's just not getting any results. Are you using CloudLinux w/PHP Selector or can you tell me more about the configuration of the server.
 

CubeSyVal

Registered
Jun 12, 2019
2
0
1
Australia
cPanel Access Level
DataCenter Provider
Ah, looks like it's just a bit old and I found what the problem was.
It returns this error when it is just using the base PHP on the server. It's on 5.3 currently, and every account has to be on 5.3 with no MultiPHP or account-level php selection. Thanks.
 

cPanelLauren

Forums Analyst II
Staff member
Nov 14, 2017
6,762
535
263
Houston
cPanel Access Level
DataCenter Provider
Again, this is not an error, there is just no output.

It's on 5.3 currently, and every account has to be on 5.3 with no MultiPHP or account-level php selection
I'm not sure I understand what you mean by the following - all easyapache 4 servers use MutliPHP to Manage PHP versions the only instance which I've found this will not provide output is if you're utilizing php selector.