The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

why apache run as nobody in fcgi ?

Discussion in 'Security' started by activa, Jan 14, 2013.

  1. activa

    activa Well-Known Member

    Joined:
    May 23, 2006
    Messages:
    204
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Morocco
    cPanel Access Level:
    Root Administrator
    Hello .

    i have found some httpd request run as nobody in FCGI mode . i know that the apache run as the user in php scripts . but i touch that the apache run as the apache or the www user .



    the probleme i have now , i have set a modsecurity rule that execute a bachscript to send email . this email is not sent because i have already disabled the send message as nobody in the tweak .

    is thier any fix to that or any tips to get the email sent ?
     
  2. SB-Nick

    SB-Nick Well-Known Member

    Joined:
    Aug 26, 2008
    Messages:
    134
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    If you are seeing lots of nobody threads you probably have the FastCGI PHP Handler misconfigured, try recompiling PHP with easyapache and re-setting the PHP Handler to FastCGI.

    As for the bash script goes, that doesnt have anything to do with your PHP setup. Try running the bash script through SSH while looking at "tail -f /var/log/exim_mainlog" on another window and see if it goes through.
     
  3. activa

    activa Well-Known Member

    Joined:
    May 23, 2006
    Messages:
    204
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Morocco
    cPanel Access Level:
    Root Administrator
    i have already do what you have mentioned .

    what i have a rule of modescurity that execute a script (exec:/root/email.lua)

    this lua script is sending email , by the server reject the email because it was exucuted as nobody . i have tried to chwon to root , user account , apache2 , www , and nothing changed .

    is thier any tips for this ?
     
  4. LasseTK

    LasseTK Active Member

    Joined:
    Apr 15, 2005
    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    6
    I had the same issue, but after enabling Apache suEXEC under "Configure PHP & suEXEC" it seems to work just fine.
     
Loading...

Share This Page