why apache run as nobody in fcgi ?

activa

Well-Known Member
May 23, 2006
212
0
166
Morocco
cPanel Access Level
Root Administrator
Hello .

i have found some httpd request run as nobody in FCGI mode . i know that the apache run as the user in php scripts . but i touch that the apache run as the apache or the www user .



the probleme i have now , i have set a modsecurity rule that execute a bachscript to send email . this email is not sent because i have already disabled the send message as nobody in the tweak .

is thier any fix to that or any tips to get the email sent ?
 

SB-Nick

Well-Known Member
Aug 26, 2008
175
9
68
cPanel Access Level
Root Administrator
If you are seeing lots of nobody threads you probably have the FastCGI PHP Handler misconfigured, try recompiling PHP with easyapache and re-setting the PHP Handler to FastCGI.

As for the bash script goes, that doesnt have anything to do with your PHP setup. Try running the bash script through SSH while looking at "tail -f /var/log/exim_mainlog" on another window and see if it goes through.
 

activa

Well-Known Member
May 23, 2006
212
0
166
Morocco
cPanel Access Level
Root Administrator
i have already do what you have mentioned .

what i have a rule of modescurity that execute a script (exec:/root/email.lua)

this lua script is sending email , by the server reject the email because it was exucuted as nobody . i have tried to chwon to root , user account , apache2 , www , and nothing changed .

is thier any tips for this ?
 

LasseTK

Active Member
Apr 15, 2005
33
0
156
I had the same issue, but after enabling Apache suEXEC under "Configure PHP & suEXEC" it seems to work just fine.