why GD Librery & FreeType requires to run captcha ???

crazyaboutlinux

Well-Known Member
Nov 3, 2007
939
1
66
Hello,

captcha images is not displaying, further searching on google we have come to know that it requires GD Librery & FreeType

why GD Librery & FreeType requires to run captcha ???, it was working fine on the server suddenly it stopped working

also if its compulsory requires to enable on server then please let us know how to do that


i have tried followings scripts but none of these working

/scripts/easyapache --enable-gd-freetype
/scripts/easyapache --enable-freetype
/scripts/easyapache --with-freetype
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
You should simply be able to add GD and TTF (FreeType) during EasyApache compile itself. Have you tried running /scripts/easyapache and then selecting those two modules in Step 6's Exhaustive Options list?

You can see after you recompile if they are enabled with the following commands:

Code:
php -m | grep -i gd
php -i | grep FreeType
 

crazyaboutlinux

Well-Known Member
Nov 3, 2007
939
1
66
but why working website stopped suddenly ??

we had only GD library now its required FreeType ? is there any component update by cpanel lately ??
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,227
463
Hello :)

This depends on the exact script you have installed that uses the captcha system. It's possible it's not related to GD/FreeType, and the problem is related to the script itself. Have you tried contacting the support for this script to see if it is a known issue?

Thank you.