Why httpd is down every time I add an add on domain in cpanel

septi

Active Member
Dec 27, 2012
39
0
6
cPanel Access Level
Root Administrator
Every time I do that the whole server is down for a few minutes. Are there any good solution?

Should I wait a while before adding a new add on domains?
 
Last edited:

quietFinn

Well-Known Member
Feb 4, 2006
1,222
87
178
Finland
cPanel Access Level
Root Administrator
What do you mean by "the whole server is down"?
 

septi

Active Member
Dec 27, 2012
39
0
6
cPanel Access Level
Root Administrator
after I add add on domains, any other domains on the server stop working. It's only for a while. However, it's annoying given that I have 1200 add on domains to add.

Restarting httpd solve the problem.
 

septi

Active Member
Dec 27, 2012
39
0
6
cPanel Access Level
Root Administrator
The problem can be fixed by reducing traffic for a while first or not creating those add on domains too quickly. Still I want to know what's going on.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,203
363
Hello :)

Do you notice any output to the Apache or cPanel error logs when adding the domain names? Check the output when adding the domain names to see if you notice any specific errors:
Code:
# tail -f /usr/local/apache/logs/error_log
# tail -f /usr/local/cpanel/logs/error_log
Thank you.
 

septi

Active Member
Dec 27, 2012
39
0
6
cPanel Access Level
Root Administrator
Ah I see. httpd is restarted every time an add on domain is added. When the server has huge load the restart takes a very long time. I wonder if we can postpone this restart behavior until all 500 domains are added for example?
 

septi

Active Member
Dec 27, 2012
39
0
6
cPanel Access Level
Root Administrator
This is what I got:
[Sun Dec 30 22:37:44 2012] [error] [client 177.42.189.161] File does not exist: /home2/randomvi/public_html/admirablepictures.com/404.shtml
[Sun Dec 30 22:37:45 2012] [notice] Graceful restart requested, doing restart
[Sun Dec 30 22:42:17 2012] [notice] SSL FIPS mode disabled
[Sun Dec 30 22:42:17 2012] [notice] Apache/2.2.23 (Unix) mod_ssl/2.2.23 OpenSSL/1.0.0-fips mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 configured -- resuming normal operations
[Sun Dec 30 22:42:38 2012] [error] [client 186.237.50.70] File does not exist: /home2/randomvi/public_html/proadultdating.com/favicon.ico
full 5 minutes to restart apache.

During that time:

[2012-12-30 22:37:36 -0600] info [ensure_vhost_includes] 'local' datastore in use (/var/cpanel/conf/apache/local)
 

septi

Active Member
Dec 27, 2012
39
0
6
cPanel Access Level
Root Administrator
Here I try again:
[Sun Dec 30 23:11:18 2012] [notice] Graceful restart requested, doing restart
[Sun Dec 30 23:18:01 2012] [notice] SSL FIPS mode disabled
[Sun Dec 30 23:18:01 2012] [notice] Apache/2.2.23 (Unix) mod_ssl/2.2.23 OpenSSL/1.0.0-fips mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 configured -- resuming normal operations

[2012-12-30 23:11:17 -0600] info [parkadmin] Creating Addon domain 'massadult.com' on 'massadult.freemarketforever.com'.
[2012-12-30 23:11:23 -0600] info [parkadmin] 'local' datastore in use (/var/cpanel/conf/apache/local)
/usr/local/cpanel/bin/ftpadmin : Syncing Ftp Databases....
[2012-12-30 23:13:42 -0600] info [cpmysqladmin] Creating MySQL database freemark_massadult for user freemark
- - - Updated - - -

Looks to me that local datastore in use is the problem. 6 minute to restart apache.
 
Last edited: