The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Why is public_html chmoded to 750?

Discussion in 'General Discussion' started by pingo, Oct 31, 2003.

  1. pingo

    pingo Well-Known Member

    Joined:
    Nov 16, 2002
    Messages:
    430
    Likes Received:
    0
    Trophy Points:
    16
    Neither the client or me touched this account. Does anybody here know why something like this suddenly happens at the server? There have been a few more cases. Do I have to run a cronjob to chmod 755 /home/*/public_html every day - arrgh - :confused:

    John
     
  2. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    No, this is an option you selected in "Upgrade Apache". It says, "Prevent Users from reading other webroots". Those permissions will work if you chown the public_html folder USERNAME:nobody
    Otherwise you could disable the feature.
     
    #2 casey, Nov 1, 2003
    Last edited: Nov 1, 2003
  3. pingo

    pingo Well-Known Member

    Joined:
    Nov 16, 2002
    Messages:
    430
    Likes Received:
    0
    Trophy Points:
    16
    Thank you!

    John
     
  4. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
  5. funkymonkey

    funkymonkey Registered

    Joined:
    Sep 22, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    how do you disable it? I'm not sure if I'm doing this right, but I tried it out by enabling it then updating apache. One of my clients reported that some of the scripts now stopped running because they could not access files across different accounts (different usergroups).

    I've found /scripts/enablefileprotect but there's no script to reverse it, and unticking and recompiling apache dosen't seem to do the trick. Using symlinks to get around it is a little tedious.
     
  6. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    Just chmod it 755 and don't choose the option when running easyapache next time. That'll do the trick.
     
  7. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    AFAIK, You can also just remove /var/cpanel/fileprotect

    However, it is an extremely good security layer.
     
  8. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Are you running with acls ?

    Have you run /scripts/initacls ?
     
  9. funkymonkey

    funkymonkey Registered

    Joined:
    Sep 22, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Cheers for the help guys, I tried removing /var/cpanel/fileprotect but it didn't do the trick, I still couldn't use certain directories that needed access accross accounts (even after a system reboot).

    The suggestion about using ACL's helped a lot though, after a bit of reading up I figured out how to use them, and I couldn't find the /scripts/initacls, so I just went ahead and used:
    mount / -o remount,acl

    which now seems to work a treat as only the shared directories are accessible across account and the rest are protected. Awesome, exactly what I wanted.
     
Loading...

Share This Page