rohit09

Well-Known Member
Dec 10, 2010
61
0
56
I wanted to on the perl to install Git. But it's show they are off. How do I back on?

Setting up magicloader
Configuring perl magic....Off
Configuring php-pear magic....Off
Configuring ruby magic....Off
Configuring php-pecl magic....Off

Thanks
 

rohit09

Well-Known Member
Dec 10, 2010
61
0
56
Code:
[email protected] # yum install git
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.maeh.org
 * extras: centos.intergenia.de
 * updates: centos.intergenia.de
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package git.x86_64 0:1.7.1-3.el6_4.1 will be installed
--> Processing Dependency: perl-Git = 1.7.1-3.el6_4.1 for package: git-1.7.1-3.e                                                                             l6_4.1.x86_64
--> Processing Dependency: perl(Git) for package: git-1.7.1-3.el6_4.1.x86_64
--> Processing Dependency: perl(Error) for package: git-1.7.1-3.el6_4.1.x86_64
--> Finished Dependency Resolution
Error: Package: git-1.7.1-3.el6_4.1.x86_64 (base)
           Requires: perl-Git = 1.7.1-3.el6_4.1
Error: Package: git-1.7.1-3.el6_4.1.x86_64 (base)
           Requires: perl(Error)
Error: Package: git-1.7.1-3.el6_4.1.x86_64 (base)
           Requires: perl(Git)
 You could try using --skip-broken to work around the problem
** Found 19 pre-existing rpmdb problem(s), 'yum check' output follows:
alsa-lib-devel-1.0.22-3.el6.x86_64 has missing requires of alsa-lib = ('0', '1.0                                                                             .22', '3.el6')
alsa-lib-devel-1.0.22-3.el6.x86_64 has missing requires of libasound.so.2()(64bi                                                                             t)
ffmpeg-libs_1.1-1.1.5-2.el6.x86_64 has missing requires of libasound.so.2()(64bi                                                                             t)
ffmpeg-libs_1.1-1.1.5-2.el6.x86_64 has missing requires of libasound.so.2(ALSA_0                                                                             .9)(64bit)
ffmpeg-libs_1.1-1.1.5-2.el6.x86_64 has missing requires of libasound.so.2(ALSA_0                                                                             .9.0rc4)(64bit)
jack-audio-connection-kit-0.121.3-1.el6.x86_64 has missing requires of libasound                                                                             .so.2()(64bit)
jack-audio-connection-kit-0.121.3-1.el6.x86_64 has missing requires of libasound                                                                             .so.2(ALSA_0.9)(64bit)
jack-audio-connection-kit-0.121.3-1.el6.x86_64 has missing requires of libasound                                                                             .so.2(ALSA_0.9.0rc4)(64bit)
1:java-1.6.0-openjdk-1.6.0.0-7.1.13.4.el6_5.x86_64 has missing requires of libas                                                                             ound.so.2()(64bit)
1:java-1.6.0-openjdk-1.6.0.0-7.1.13.4.el6_5.x86_64 has missing requires of libas                                                                             ound.so.2(ALSA_0.9)(64bit)
1:java-1.6.0-openjdk-1.6.0.0-7.1.13.4.el6_5.x86_64 has missing requires of libas                                                                             ound.so.2(ALSA_0.9.0rc4)(64bit)
libgcj-4.4.7-4.el6.x86_64 has missing requires of libasound.so.2()(64bit)
libgcj-4.4.7-4.el6.x86_64 has missing requires of libasound.so.2(ALSA_0.9)(64bit                                                                             )
libsndfile-1.0.20-5.el6.x86_64 has missing requires of libasound.so.2()(64bit)
libsndfile-1.0.20-5.el6.x86_64 has missing requires of libasound.so.2(ALSA_0.9)(                                                                             64bit)
libsndfile-1.0.20-5.el6.x86_64 has missing requires of libasound.so.2(ALSA_0.9.0                                                                             rc4)(64bit)
unicap-0.9.5-7.el6.x86_64 has missing requires of libasound.so.2()(64bit)
unicap-0.9.5-7.el6.x86_64 has missing requires of libasound.so.2(ALSA_0.9.0rc4)(                                                                             64bit)
unicap-0.9.5-7.el6.x86_64 has missing requires of libasound.so.2(ALSA_0.9)(64bit                                                                             )
[email protected]
 
Last edited by a moderator:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,228
463
Hello :)

cPanel & WHM versions 11.36 and newer include the Git software. The Git installation location is /usr/local/cpanel/3rdparty/bin/git. You can find documentation on GIT here:

cPanel - GIT

Thank you.