The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

why /scripts/restartsrv_exim have changed the manner it works?

Discussion in 'General Discussion' started by docenta, May 18, 2006.

  1. docenta

    docenta Well-Known Member

    Joined:
    May 9, 2006
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    Hello here is the result from using the /scripts/restartsrv_exim today:



    /scripts/restartsrv_exim
    Starting clamd: [ OK ]
    Starting exim-26: [ OK ]
    Starting exim: [ OK ]
    Starting exim-smtps: [ OK ]
    Starting antirelayd: [ OK ]
    Starting antirelayd: [ OK ]



    before it was :



    /scripts/restartsrv_exim
    Starting clamd: [ OK ]
    Starting exim-26: [ OK ]
    Starting exim: [ OK ]
    Starting exim-smtps: [ OK ]
    Starting antirelayd: [ OK ]
    Starting spamd: [ OK ]



    I see the script have the same old date.


    What was changed so the script do not restart my spamd ?




    Thanks.
     
  2. webignition

    webignition Well-Known Member

    Joined:
    Jan 22, 2005
    Messages:
    1,880
    Likes Received:
    0
    Trophy Points:
    36
    /scripts/restartsrv_exim just uses the OS's method for restarting Exim.

    Whatever is responsible for the change, it won't be the script.

    Which OS are you running?
     
  3. docenta

    docenta Well-Known Member

    Joined:
    May 9, 2006
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    Cent OS 3.7
     
  4. webignition

    webignition Well-Known Member

    Joined:
    Jan 22, 2005
    Messages:
    1,880
    Likes Received:
    0
    Trophy Points:
    36
    Try:

    Code:
    service exim restart
    from root shell. If you get the same output, you can be sure it's not related to the script.

    Check /etc/rc.d/init.d/exim - has this changed recently?
     
  5. docenta

    docenta Well-Known Member

    Joined:
    May 9, 2006
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    ni is not changed recently :


    ls -la /etc/rc.d/init.d/exim
    -rwxr-xr-x 1 root root 4141 Jul 28 2005 /etc/rc.d/init.d/exim*
     
  6. docenta

    docenta Well-Known Member

    Joined:
    May 9, 2006
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    what is this file ? should I delete it ?




    -rw-r--r-- 1 root root 0 May 18 23:33 /etc/spamdisable
     
  7. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    That simply means that you've disabled SpamAssassin in either WHM > Tweak Settings or WHM > Service Manager > spamd, I forget which one disables it completely.
     
  8. docenta

    docenta Well-Known Member

    Joined:
    May 9, 2006
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    No in tweak settings is enabled and it is enabled in service manager too.
    But with command /scripts/restartsrv_exim is not starting like before.
     
Loading...

Share This Page