Why TTL on cPanel DNSOnly is fixed?

kbn

Registered
May 9, 2013
1
0
1
cPanel Access Level
Root Administrator
Hello.

My English isn't very good.
I hope my English mistakes haven't put you off.

I have two servers.
One is cPanel/WHM installed. Another one is cPanel DNSOnly installed.
cPanel/WHM is primary DNS server(NSD), cPanel DNSOnly is secondly DNS server(MyDNS).

I set that TTL is 14400(default) on cPanel/WHM.
But when I add a domain on WHM, secondly DNS server's TTL is fixed to 86400.

Primary:
Code:
# dig @primary-dns mail.example.com a
example.com.            14400   IN      A       192.168.0.1
Secondly:
Code:
# dig @secondly-dns mail.example.com a
example.com.            86400   IN      A       192.168.0.1
14400 is written in /var/named/example.com.db on secondly DNS server.
But 86400 is written in MySQL record of MyDNS on secondly DNS server.

My guess is that if I use BIND, then TTL will be correct.
However, I want using MyDNS.

Is there anything I should confirm?

Thanks!
 

jameshsi

Well-Known Member
Oct 22, 2001
347
0
316
Hello.

My English isn't very good.
I hope my English mistakes haven't put you off.

I have two servers.
One is cPanel/WHM installed. Another one is cPanel DNSOnly installed.
cPanel/WHM is primary DNS server(NSD), cPanel DNSOnly is secondly DNS server(MyDNS).

I set that TTL is 14400(default) on cPanel/WHM.
But when I add a domain on WHM, secondly DNS server's TTL is fixed to 86400.

Primary:
Code:
# dig @primary-dns mail.example.com a
example.com.            14400   IN      A       192.168.0.1
Secondly:
Code:
# dig @secondly-dns mail.example.com a
example.com.            86400   IN      A       192.168.0.1
14400 is written in /var/named/example.com.db on secondly DNS server.
But 86400 is written in MySQL record of MyDNS on secondly DNS server.

My guess is that if I use BIND, then TTL will be correct.
However, I want using MyDNS.

Is there anything I should confirm?

Thanks!
Second that!
I face the same issue here.

Have no idea how to fix this dam issue.
 

Yuri

Registered
Aug 22, 2006
4
2
153
Brazil
To anyone that still have this problem with MyDNS.

By default the MyDNS is configured to follow the minimum TTL in SOA records of a domain but for some reason the default minimum TTL used by DNS Zones created by cPanel is 86400!

So when you try to use de MySQL all DNSs entries with TTL less than minimum will by increased to minimum.

But fortunately the MySQL have an option to workaround this.

Just edit the /etc/mydns.conf and change:

ignore-minimum = no

To:

ignore-minimum = yes


And the MyDNS will start to ignore the SOA minimum TTL just like the BIND and NSD does.