The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Why when delete an MX record from MX entry, this delete an default A record to server?

Discussion in 'General Discussion' started by tolostoi, May 11, 2013.

  1. tolostoi

    tolostoi Registered

    Joined:
    May 11, 2013
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Hi to all,
    I use cpanel without advanced dns editor, just simple dns editor. When I decided to delete mx record (because i don't need mail boxes for this domain, but recieve many spam) this delete an A record for the domain (without asking)? How can revert this actoion? How this is possible? I have permition to delete something, but not to create to? I just delete an mx record ... why the A record desapear too :(
    I try to create A record
    mydomain.ru to server ip address and red baner tells me:
    Error
    You must have the zoneedit feature to take this action. You currently only have the simplezoneedit feature.

    In simple dns editor I have this records:

    localhost.XXXus.ru. A 127.0.0.1 Delete
    mail.XXXus.ru. CNAME XXXus.ru Delete
    ftp.XXXus.ru. CNAME XXXus.ru Delete
    autoconfig.XXXus.ru. A 91.1XX.1XX.61 Delete
    autodiscover.XXXus.ru. A 91.1XX.1XX.61 Delete
    webdisk.XXXus.ru. A 91.1XX.1XX.61 Delete

    I try to revert action, create new mx entry

    Priority: 0
    Destination: XXXus.ru

    Now I have MX record wihout A record to server :eek:

    :~$ host XXXus.ru
    XXXus.ru mail is handled by 0 XXXus.ru.



    e:~$ dig XXXus.ru

    ; <<>> DiG 9.9.2-P1 <<>> XXXus.ru
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 1671
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1

    ;; OPT PSEUDOSECTION:
    ; EDNS: version: 0, flags:; udp: 4096
    ;; QUESTION SECTION:
    ;XXXus.ru. IN A

    ;; AUTHORITY SECTION:
    XXXus.ru. 8877 IN SOA ns1.maxXXX.bg. office.maxXXX.bg. 2013051002 86400 7200 3600000 86400

    ;; Query time: 2 msec
    ;; SERVER: 127.0.1.1#53(127.0.1.1)
    ;; WHEN: Sat May 11 10:53:11 2013
    ;; MSG SIZE rcvd: 96


    Thanks in advance.
     
  2. tolostoi

    tolostoi Registered

    Joined:
    May 11, 2013
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Great forum :rolleyes:
    I solved the problem.
    In section parked domains, must delete the row with desired domain name, then create again, and the default A record for domain.com will appear again.
    Just great decision from cpanel, when decided to delete a mail, the whole website is down for no reason :eek:
     
Loading...

Share This Page