The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Wildcard Certificate issues

Discussion in 'General Discussion' started by Smitty519, Jul 28, 2010.

  1. Smitty519

    Smitty519 Member

    Joined:
    Jun 15, 2008
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    I'm the (new) server administrator for a large non profit. We purchased a wildcard certificate from Digi Cert and are attempting to use it on one of our servers that has a shared IP and several [sub]domains with cpanel/whm 11.25.

    I've tried to research this and have found answers from you can't do it to it works great. Nowhere have I found how to make it work. When I test one of the domains with Digi Cert's tester, I get an error that says the intermediate certificate is not being sent. Their instructions for fixing this include the modification of the httpd.conf file to add a SSLCertificateChainFile statement for each domain that uses the certificate.

    When I do that, the issue with their tester is resolved. However, the changes go away any time that whm rebuilds the httpd.conf file. How can I make whm do this correctly?

    --Smitty
     
  2. thobarn

    thobarn Well-Known Member

    Joined:
    Apr 25, 2008
    Messages:
    153
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    sanctum sanctorum
Loading...

Share This Page