The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Wildcard DNS not working on Apache

Discussion in 'Bind / DNS / Nameserver Issues' started by LucasMS, Mar 21, 2008.

  1. LucasMS

    LucasMS Registered

    Joined:
    Mar 13, 2008
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Hi

    I've setup the wildcard DNS for my apache webserver. But when I type something.domain.com in the browser, I see the default cpanel page:

    Code:
    Great Success !
    Apache is working on your cPanel® and WHM™ Server
    not the files in the domain.com .

    some parts of my httpd.conf file:


    Code:
    NameVirtualHost IPADDRESS:80
    NameVirtualHost *
    
    <VirtualHost IPADDRESS:80>
        ServerName srv.host.com
        DocumentRoot /usr/local/apache/htdocs
        ServerAdmin webmaster@host.com
        <IfModule mod_suphp.c>
            suPHP_UserGroup nobody nobody
        </IfModule>
    </VirtualHost>
    
    
    # Default vhost for unbound IPs
    <VirtualHost IPADDRESS:80>
        ServerName srv.host.com
        DocumentRoot /usr/local/apache/htdocs
        ServerAdmin webmaster@host.com
        <IfModule mod_suphp.c>
            suPHP_UserGroup nobody nobody
        </IfModule>
    </VirtualHost>
    
    <VirtualHost IPADDRESS:80>
        ServerName domain.com
        ServerAlias *.domain.com
        DocumentRoot /home/domaincom/public_html
        ServerAdmin webmaster@domain.com
    </VirtualHost>
    
     
Loading...

Share This Page