The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Wildcard in DNS Zone Template

Discussion in 'Bind / DNS / Nameserver Issues' started by mwaterous, Sep 22, 2010.

  1. mwaterous

    mwaterous Member

    Sep 19, 2010
    Likes Received:
    Trophy Points:
    I just set up cPanel/WHM for the first time today, and while I'm already missing doing everything by hand, my clients will need this so I'm pushing forward.

    I set up a domain earlier, and when I tried to add a sub-domain through the cPanel interface for the domain it was failing to resolve. I checked the DNS Zone for the domain and it there was an A record added for it, but nevertheless it wasn't working. The other A records added by the template (cpanel, www, etc) all resolved just fine.

    The new subdomain only started working after adding a wildcard entry to the zone. I'm no expert with DNS, but every other DNS system I've worked with there has always been a blank or @ record for the primary IP. Should I add one of these, or the wildcard to the template to ensure this doesn't occur again?

    Also is there something I can edit to stop it from creating www.subdomain a records? When a subdomain is added, I just want the subdomain, not www.subdomain as well.

    Thanks in advance!

Share This Page