The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Wildcard SSL certificate installed, but not working when I install subdomains on accounts.

Discussion in 'General Discussion' started by cass, Jun 3, 2013.

  1. cass

    cass Well-Known Member

    Jul 17, 2002
    Likes Received:
    Trophy Points:
    I have one problem... maybe is not a problem, i want to make sure this is the correct way to do this.

    and got a DOMAIN.COM wildcard certificate, that is intalled, shared, and works on all services okey.
    when you put ir works, etc. as well with webmail, cpanel ,etc.

    Now.... On I want to put a addon domain, to be able to use the wildcard SSL cert. I can create it okey, and it works.... with http:// ... but when you put https:// it shows default cpanel site, as non existent, ip error, etc.

    Does I need to "Install a SSL Certificate" AGAIN and AGAIN for every "add on subdomain" added to any account?
    I tried adding it this way, and it works, but not sure if its the way to do this... or if there is some "enable ssl" or something like.

    So its like on HTTP is only created the :80 vhost, wich is okey... so the way to create the :443 vhost for the SSL is doing it via the Install a SSL Certificate again? even when the cert is already installed? or there is another easy way of doing this ?

  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Apr 11, 2011
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Root Administrator
    Hello :)

    Prior to cPanel version 11.38, wildcard SSL is not natively supported. You have to follow the manual workaround method provided at:

    SSL Certificates Across Multiple Hosts

    cPanel version 11.38 offers improved wildcard and UCC/SAN certificate support, and allows users to use the same certificate for multiple subdomains. You can find the release notes at:

    11.38 - Improved SSL Management System

    cPanel version 11.38 is currently only available in the "Edge" and "Current" build tiers, so it's not yet intended for production machines. You may want to consider waiting for it to be pushed to the "Release" build tier if you do not want to use the unsupported custom workaround in the forum post mentioned above.

    Thank you.

Share This Page