Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Wildcard SSL + Redirection Problem

Discussion in 'General Discussion' started by skina, Jan 21, 2008.

  1. skina

    skina Member

    Joined:
    Sep 21, 2007
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    51
    I have purchased and installed a wildcard SSL cerfiticate on the same domain as my hostname.

    I have been able to get hostname.mydomain.co.uk to correctly use the new certificate.

    However, I wish to also use the SSL certificate for https://webmail.mydomain.co.uk which points to a custom webmail installation.

    http://webmail.mydomain.co.uk works fine and points to the webmail app.

    However, https://webmail.mydomain.co.uk redirects to https://www.mydomain.co.uk which is not what I want to happen. However, http://www.mydomain.co.uk is correctly secured with the new certificate.

    Any ideas why this redirection is occuring?

    Thanks in advance.

    Daniel
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. skina

    skina Member

    Joined:
    Sep 21, 2007
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    51
    If It helps I have made manula changes to httpd.conf to get it working. However, I am afraid that as soon as the httpd.conf is rebuilt I will loose the changes and it will go back to not working as I expect.

    Here is what I added. First note that the VirtualHost record for webmail.mydomain.co.uk comes before the record for *.mydomain.co.uk. Initially the record for wemail.my.domain.co.uk was not SSL enabled. So:
    • I changed the port to 443
    • I copied and pasted the SSL directives from *.

    Saving the edited config and restarting apache makes it work exactly as I would like. How do I make sure that these changes are preserved during subsequent config rebuilds? The distiller won't work as the changes have been made in VirtualHost records.

    Thanks

    Daniel
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice