Will both php 4 and 5 work correctly if i disable fast cgi?

utube

Registered
Aug 22, 2009
4
0
51
If i disable Mod_FCGID , CGI and Fastcgi on both php4 and php5 on /scripts/apache , will php4 and php5 work properly?
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
I'm not sure I understand the question, are PHP 4 and PHP 5 both not working properly?
 

utube

Registered
Aug 22, 2009
4
0
51
if i compile apache without those modules, will php4 and 5 work properly? isn't php5 configured with fast cgi?
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
PHP 5 does not require fastcgi in any way if you aren't going to be using FCGI. PHP 5 can use DSO, suPHP, FCGI or CGI. What handler are you going to be using even?
 

utube

Registered
Aug 22, 2009
4
0
51
im planing to disable FCGI, DSO, SuPHP FCGI and CGI , so will php 4 and php5 work on cpanel?
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
If you disable every single handler for PHP, then you cannot use PHP, since PHP has to have some handler. If you only disable FCGI and FastCGI, then you can use DSO, suPHP and CGI for handlers.

As such, what handler were you going to use for PHP, or is the actual goal to entirely remove PHP support?