Will my GoDaddy shared hosting account be affected by the forced EasyApache3 to EasyApache4 update?

Outlier

Active Member
Apr 21, 2017
25
1
3
Los Angeles
cPanel Access Level
Root Administrator
I just purchased GoDaddy's Ultimate hosting plan which is shared hosting. It uses cPanel. I'm wondering if this hosting account will be affected by the forced EasyApache3 to EasyApache4 update? Do shared hosting accounts even use EasyApache? Can anyone please confirm?
 

HostNoc

Well-Known Member
Feb 20, 2020
93
17
8
Ontario
cPanel Access Level
Root Administrator
Hello @Outlier

The EasyApache is part of the WHM and since you have a Shared Hosting account, any changes that is made by your host and causes any issues to your site its the hosting provider responsiblility.

Still to your question, EasyApache3 to EasyApache4 update might affect your site and not your hosting account, the site can be distorted if there is any php versions module changes/upgrades that does not work with the site code, other than php changes it should not have any impact to your site.

Regards,
 

Outlier

Active Member
Apr 21, 2017
25
1
3
Los Angeles
cPanel Access Level
Root Administrator
My hosting account only gives me cPanel, I do not have WHM. And from cPanel I do not see anything to do with EasyApache. That's why I'm wondering if my shared hosting account even uses EasyApache? Is EasyApache only available on private servers?

Regarding PHP changes, on cPanel there is an option where I can select my PHP version on the button where it says "Select PHP Version." If I keep the version that I'm using, 5.6, then I probably shouldn't run into any problems. So just seeing this option in cPanel gives me peace of mind but are you saying that the hosting provider can still somehow make changes to my PHP version?

In the end, I'm just concerned about a forced upgrade from EA3 to EA4 and if it will affect my site. Since I don't see any option for EasyApache on my cPanel, I'm not even sure if it uses EasyApache at all. Should I be concerned or will this forced update not affect me?
 

Rajeeva Lochana

Well-Known Member
Community Guide Contributor
May 27, 2019
122
38
28
India
cPanel Access Level
Root Administrator
@Outlier most likely no! GoDaddy is a huge server provider, and they won't let you down easily. You can only see EasyApache in the WHM page, which you can access only if you purchase a VPS or a Dedicated Server. since you are on a shared hosting. You probably wouldn't need to worry. if you have problems, you can contact GoDaddy, and they will most likely resolve your problem. You are not responsible for any errors caused by the upgrade. The hosting provider (GoDaddy as you mentioned), is responsible for this. They will most likely fix any problems even before you notice them. Stop worrying and be cool. And, I am curious about how you know that they have EasyApache 3 right now?
 

Outlier

Active Member
Apr 21, 2017
25
1
3
Los Angeles
cPanel Access Level
Root Administrator
I also have a VPS with GoDaddy which is using EasyApache 3. I got a warning email from them that there will be a forced upgrade from EA3 to EA4 this week. That's one of the reasons why I switched to the shared hosting. I don't want to have to worry about all these upgrades and security issues from time to time.

Speaking of which, the cPanel version that I have with the shared hosting is 78.0.27 but according to a cPanel document, it says that there is a Exim security issue with cPanel versions below 78.0.38. That document is here: CVE-2019-15846 Exim - cPanel Knowledge Base - cPanel Documentation Should I be worried about my cPanel version now? It is below the patched version. Or is GoDaddy so good that it will still protect me in their shared hosting?
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,295
1,273
313
Houston
A cPanel user would not have access to EasyApache, but this is a discussion for your provider on shared.

As for the VPS yes you should be concerned, you should be updating the serer regularly (this can be set to be done automatically) the exim vulnerability could result in a root level compromise. The EA3 -> EA4 migration process at this point is pretty seamless unless you have heavy customization. It's likely that you'll be unaffected. I'd suggest discussing this with your provider.
 

Outlier

Active Member
Apr 21, 2017
25
1
3
Los Angeles
cPanel Access Level
Root Administrator
I'm planning to stop using the VPS. So how about the shared hosting? Am I safe with that? Again, the shared hosting account uses cPanel 78.0.27 but according to that cPanel document I referenced earlier, it says that there is an Exim security issue with cPanel versions below 78.0.38. Should I be concerned with that or is GoDaddy a big enough provider that they will still protect me?
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,295
1,273
313
Houston
I'd talk to the hosting provider to see if they've updated the package. If the exim version is updated then you should be fine but vulnerable is vulnerable regardless of how good you believe the provider to be.
 
  • Like
Reactions: Rajeeva Lochana

Rajeeva Lochana

Well-Known Member
Community Guide Contributor
May 27, 2019
122
38
28
India
cPanel Access Level
Root Administrator
@Outlier, take a backup of your VPS only once. Don't stop using it just because of this. Upgrade EasyApache3 to EasyApache4, see if there are any errors. If there are, just restore your backup only once, or, your cPanel License will most likely not work anymore due to duplications and stuff, so restore it only once. GoDaddy has this feature, so if you have the VPS on GoDaddy, you can do this extremely easily. Go have a look at https://in.godaddy.com/help/back-up-my-gen-3-server-12271 if you have Gen3 VPS, or go have a look at https://in.godaddy.com/help/back-up-my-gen-4-server-27819 if you have Gen4 VPS. Only if you use GoDaddy for your VPS. Restoring your snapshot too many times is not encouraged.