The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

will not upgrade to php 4.3.8

Discussion in 'General Discussion' started by jkt, Aug 24, 2004.

  1. jkt

    jkt Member

    Joined:
    Aug 23, 2004
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Hi,
    I tried to upgrade my php from 4.3.3 to 4.3.8 by going to WHM and clicking on update apache link.
    The page that comes up shows both php 4.3.3 and 4.3.8 selected so I uncheck php module 4.3.3, and left the 4.3.8 selected as it was, also everything else is left as the default install.

    The process tell me RPM package 4.0.4
    Buildapache 9.4.1a

    It restarts httpd, and tell me build okay and complete, but when I check again my php is the same as before version 4.3.3 and did not upgrade to 4.3.8

    I have Cpanel/WHM 9.4.1-R64 (Release tree) on Linux server
    Apache 1.3.31 installed.
    PHP 4.3.3
    Zend optimizer 2.5.1 installed

    Why is it not upgrading to php 4.3.8

    Any help is appreciated, thanks
     
  2. haze

    haze Well-Known Member

    Joined:
    Dec 21, 2001
    Messages:
    1,550
    Likes Received:
    3
    Trophy Points:
    38
    The problem is most probably due to a module not building for php ( or even apache ). What errors if any do you see while buildapache is running ?

    What you may want to do is re-run the install but select minimal php modules. After that is complete ( and if successfully upgraded ) try running the installer again with the modules you want.
     
  3. jkt

    jkt Member

    Joined:
    Aug 23, 2004
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    can not upgrade to php 4.3.8

    I did not see any errors, also it did not look that it was even trying to download the php module, like for some reason it was skipping the upgrade instruction for the php, and left the php the same as existing instaled one(4.3.3).

    I left the default selected modules, which I assume should be the bare minimum php modules.

    Also I have zend optimizer installed, could that be the cause of it. Has anyone done the php upgrade with zend optimizer installed in their existing php.

    And NO, I do NOT have mm cache installed.

    Would appreciate more feed back on this, thanks
     
  4. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16
    Leave both php mods checked and it will build 4.3.8 for you
     
  5. jkt

    jkt Member

    Joined:
    Aug 23, 2004
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    can not upgrade to php 4.3.8

    Are you sure about this? Have you actualy done it this way yourself.

    I was told by the server admin, to Unselect the php 4.3.3 module, and leave the selected php 4.3.8 as it was

    Thanks
     
  6. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    Yes, he is correct. First, you have to select the php module, then you have to select the version you want. Unfortunately, php module has (4.3.3) in parenthesis which is very confusing and not accurate. Select them both and you can upgrade.
     
  7. jkt

    jkt Member

    Joined:
    Aug 23, 2004
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    will not upgrade to 4.3.8

    Thanks to both of you for the info. It did work, and it upgraded to php 4.3.8

    And you were right about looking at the php module (4.3.3) was confusing.

    So lesson to future newbees, that want to upgrade their php

    1) Go to your WHM
    2) Click on update Apache link at the left
    3) Keep PHP module selected
    4) Select the php version that you want to upgrade to.

    Thanks again
     
Loading...

Share This Page