Will upgrading EA3 to EA4 affect my versions of PHP and MySQL?

Outlier

Member
Apr 21, 2017
20
0
1
Los Angeles
cPanel Access Level
Root Administrator
I got an email from my host GoDaddy that said cPanel will be forcing all servers to update from EA3 to EA4 which could break the site. If I'm using PHP 5.6 and MySQL 5.5, will the update change my PHP version or MySQL version?
 
Last edited:

Outlier

Member
Apr 21, 2017
20
0
1
Los Angeles
cPanel Access Level
Root Administrator
I plan to do the update through WHM and here are the pre-flight check warnings that appear:

Warning: “Cpanel::Easy::PHP5::MailHeaders” ignored since it does not have an RPM.
Warning: “Cpanel::Easy::Apache::Fileprotect” ignored since it does not have an RPM.
Warning: “Cpanel::Easy::Apache::Access” ignored since it does not have an RPM.
Warning: Adding the missing package, ea-apache24-mod_suexec, to the EasyApache 4 profile.

Should I be concerned about any of those warnings? What does it mean to be "ignored since it does not have an RPM"?
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,297
1,251
313
Houston
Hello,


None of those packages are needed with EA4 as they're compiled with Apache automatically. The update will not change your PHP version and won't affect MySQL. The update will give you the ability to run different PHP versions though. Your hosting provider should provide assistance for the update and should they not we are happy to assist, just open a ticket with us.