The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Without reinstalling , can I fix issues with *.pm ?

Discussion in 'General Discussion' started by mangoimran, Oct 11, 2010.

  1. mangoimran

    mangoimran Registered

    Joined:
    Oct 11, 2010
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    We had a raid failure, and since then I'm trying to recover important data off the disk. I'm now on an image working on this, but I'm getting this :


    Compress/Zlib.pm did not return a true value at /usr/lib/perl5/site_perl/5.8.8/CPAN/SQLite/Info.pm line 6.
    BEGIN failed--compilation aborted at /usr/lib/perl5/site_perl/5.8.8/CPAN/SQLite/Info.pm line 6.
    Compilation failed in require at /usr/lib/perl5/site_perl/5.8.8/CPAN/SQLite/Index.pm line 4.
    BEGIN failed--compilation aborted at /usr/lib/perl5/site_perl/5.8.8/CPAN/SQLite/Index.pm line 4.
    Compilation failed in require at /usr/lib/perl5/site_perl/5.8.8/CPAN/SQLite.pm line 54.
    system /usr/bin/perl -MCPAN::SQLite::META=setup,update -e update failed: 2304 at /usr/lib/perl5/site_perl/5.8.8/CPAN/SQLite/META.pm line 323.
    expect: spawn id exp6 not open
    while executing
    "expect -nobrace {*perlmod--Install done*} {
    exit
    } {*Apache source not found*} {
    send "q\r"
    } {*Which SSL install path do you want to use*} ..."
    invoked from within
    "expect {
    "*perlmod--Install done*" {
    exit
    }
    "*Apache source not found*" {
    send "q\r"
    }
    "*Which SSL install path do you want to use*" {..."
    ("while" body line 2)
    invoked from within
    "while {1} {
    expect {
    "*perlmod--Install done*" {
    exit
    }
    "*Apache source not found*" {
    send "q\r"
    }
    "*Which SSL install path do you w..."
    (file "/scripts/expectperlinstaller" line 9)
    Using fast module check.....checked 120 modules in 2 second(s)
    Method: Perl Expect
    Undefined subroutine &IO::Pty::pty_allocate called at /usr/lib/perl5/site_perl/5.8.8/x86_64-linux/IO/Pty.pm line 24, <MODCHK> line 1.


    I'm unable to fix this or other issues with what is just the cpan related stuff to get the system to generate out cpanel backups. It will generate things - just without mysql dbs - because the files for those were corrupted.

    Can you point me to some things that might help me in this regards ?
     
Loading...

Share This Page