The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Wong version of php being displayed php -v

Discussion in 'General Discussion' started by mr.wonderful, Oct 28, 2004.

Thread Status:
Not open for further replies.
  1. mr.wonderful

    mr.wonderful BANNED

    Joined:
    Feb 1, 2004
    Messages:
    345
    Likes Received:
    0
    Trophy Points:
    0
    Im going mad!

    According to my phpinfo.php output Im running php 4.3.8

    php -v sayins im running

    4.1.2 :confused:

    I have search for hours, days, weeks and cannot work out where php -v is getting this. Iv looked for old versions of php and cannot find any. Im recompiled php several times and this is the output;

    Installing PHP SAPI module: apache
    [activating module `php4' in /usr/local/apache/conf/httpd.conf]
    cp libs/libphp4.so /usr/local/apache/libexec/libphp4.so
    chmod 755 /usr/local/apache/libexec/libphp4.so
    cp /usr/local/apache/conf/httpd.conf /usr/local/apache/conf/httpd.conf.bak
    cp /usr/local/apache/conf/httpd.conf.new /usr/local/apache/conf/httpd.conf
    rm /usr/local/apache/conf/httpd.conf.new
    Installing PHP CLI binary: /usr/local/bin/
    Installing PHP CLI man page: /usr/local/man/man1/
    Installing PEAR environment: /usr/local/lib/php/
    [PEAR] Archive_Tar - already installed: 1.1
    [PEAR] Console_Getopt - already installed: 1.2
    [PEAR] PEAR - already installed: 1.3.2
    Wrote PEAR system config file at: /usr/local/etc/pear.conf
    You may want to add: /usr/local/lib/php to your php.ini include_path
    [PEAR] DB - already installed: 1.6.2
    [PEAR] HTTP - already installed: 1.2.2
    [PEAR] Mail - already installed: 1.1.3
    [PEAR] Net_SMTP - already installed: 1.2.3
    [PEAR] Net_Socket - already installed: 1.0.1
    [PEAR] XML_Parser - already installed: 1.0.1
    [PEAR] XML_RPC - already installed: 1.1.0
    Installing build environment: /usr/local/lib/php/build/
    Installing header files: /usr/local/include/php/
    Installing helper programs: /usr/local/bin/
    program: phpize
    program: php-config
    program: phpextdist

    So why does php -v think im still running 4.1.2? Needless to say when i try to run zend encoded cron jobs i get errors that zend is not installed yet it is installed. My include path in php.in is correct.

    Anyone have any idea why this box thinks im still running 4.1.2?
     
  2. nickn

    nickn Well-Known Member
    PartnerNOC

    Joined:
    Jun 15, 2003
    Messages:
    619
    Likes Received:
    1
    Trophy Points:
    18
    Does php info() show the correct version? Are you using phpsuexec?
     
  3. mr.wonderful

    mr.wonderful BANNED

    Joined:
    Feb 1, 2004
    Messages:
    345
    Likes Received:
    0
    Trophy Points:
    0
    Not running phpsuexec and it says 4.3.8 but it says 4.1.2 when i type php -v via root.
     
  4. joel69

    joel69 Active Member

    Joined:
    Feb 17, 2005
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    East Vancouver, BC, Canada
    This appears to be an old thread since it is talking about outdated versions of PHP, but I am running into a similar problem with PHP 4.4.1 and 5.0.5. I did some research, and it appears I have two different copies. One is in /usr/bin, and the other is in /usr/local/bin. There is no RPM version of PHP installed, and the only installation of PHP is done via the "Apache Update" part of the WHM.

    Does anybody know why I have two different copies, and how I unify them? :confused:
     
  5. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
Loading...
Thread Status:
Not open for further replies.

Share This Page