The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Wont let me assign IP addresses as nameservers.

Discussion in 'Bind / DNS / Nameserver Issues' started by zigzam, Jun 22, 2005.

  1. zigzam

    zigzam Well-Known Member

    Joined:
    May 9, 2005
    Messages:
    206
    Likes Received:
    0
    Trophy Points:
    16
    When I go ---> manage nameserver ips ----> enter IP----> I get this error:
    Sorry, the nameserver ************8.com already has the ip ************ assigned to it. How do I override this. I have over 100 accounts that use that nameserver and I want to use that nameserver on this server. (Switched servers)

    Thanks
     
  2. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    SSH to your server, using your favorite text editor:
    /etc/nameserverips
    and modify your IPs or NSs.
     
  3. zigzam

    zigzam Well-Known Member

    Joined:
    May 9, 2005
    Messages:
    206
    Likes Received:
    0
    Trophy Points:
    16
    I get the error message:


    -bash: etc/nameserverips: Permission Denied


    I own the server so I should have all permissions
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Did you SSH in to the root account?
     
  5. bartman1

    bartman1 Member

    Joined:
    Jul 4, 2005
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    have the same problem

    only have 2 extra ips but when i goto to list ips

    my host ip is in green other ips in red
     
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Have you actually selected WHM > Tweak Settings > Allow Sharing Nameserver Ips?
     
  7. zigzam

    zigzam Well-Known Member

    Joined:
    May 9, 2005
    Messages:
    206
    Likes Received:
    0
    Trophy Points:
    16
    Yes, did that first thing.
     
  8. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Well, as Andy said, you could just edit /etc/nameserverips though, personally, I don't use that functionality in cPanel at all and simply add an A record into the zone of whichever domain I want to use as a nameserver and point it to whatever IP address I want and that's all you need to do, since bind is bound to every IP address by default anyway.
     
  9. x2o

    x2o Member

    Joined:
    May 11, 2005
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    It also most likely that the ns names already exist with the previous account and have not moved over yet.

    Just a thought.
     
Loading...

Share This Page