The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Wordpress and FTP mishap

Discussion in 'General Discussion' started by Jedinator, Jul 10, 2011.

  1. Jedinator

    Jedinator Member

    Joined:
    Jul 10, 2011
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    I installed Wordpress using Fantastico a few months ago. Recently, I decided to try some other programs to create my site. So, I deleted the SQL Database that had Wordpress. Then I deleted all traces of wordpress in the file manager.

    Next, I decided to use filezilla to upload an html file created using kompozer. The file shows up in file manager just fine in the public_html file.

    When I visit my website though, ealpha.net, all I get are a bunch of errors like:
    Warning: require(./wp-blog-header.php) [function.require]: failed to open stream: No such file or directory in /home/ealphane/public_html/index.php on line 17

    Warning: require(./wp-blog-header.php) [function.require]: failed to open stream: No such file or directory in /home/ealphane/public_html/index.php on line 17

    Fatal error: require() [function.require]: Failed opening required './wp-blog-header.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/ealphane/public_html/index.php on line 17

    What am I doing wrong? I am a super beginner, so any help is much appreciated! Thanks
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,448
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Check for and remove the index.php in the public_html directory. Sounds like you missed a file when you were removing the wordpress site incorrectly. This is a common mistake (In regard to Fantastico) you do not delete things when you want to remove a Fantastico script, you uninstall it the same way you installed it. Doing it wrong makes a mess.

    Your host can assist you with these sort of issues. ;)
     
  3. Jedinator

    Jedinator Member

    Joined:
    Jul 10, 2011
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for your help. I will try that. I would have used fantastico, but my host is switching to Softaclious, and so they removed Fantistico from Cpanel. Thanks again
     
  4. Jedinator

    Jedinator Member

    Joined:
    Jul 10, 2011
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Will I need to reinsert the index.php file?
     
  5. Jedinator

    Jedinator Member

    Joined:
    Jul 10, 2011
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    I removed the index.php file in the public_html file and now when I go to my website, it just says:
    Forbidden

    You don't have permission to access / on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
     
  6. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,448
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Sounds like a problem with your public_HTML directory. Just to troubleshoot, find your .htaccess file in public_HTML and rename it ti killl it. Try site again.
     
  7. Jedinator

    Jedinator Member

    Joined:
    Jul 10, 2011
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    I don't see a .htaccess file
    sorry, I am a total noob at this
     
  8. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,448
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Not a problem. Assuming you're looking via cPanel File Manager, the .htaccess is a hidden "dot" file. To have those diplayed to you in File Manager, at bottom of your main cPanel page find a link titled "Reset All Interface Settings" and click. The page will refresh and you get a nice pretty popup. Click "No I'm fine thanks".

    Next, click File Manager. You get a second popup, on this one, at bottom tick "Show Hidden Files" (you can go back and edit these other options on both of these popups later if you wish) and click Go.

    On left tree menu, find public_html listed and doubleclick to open on right side of page. You should now be able to view that file named .htaccess

    Here, right click > choose Rename. Name it .htaccess.txt and save. Try site.
     
  9. Jedinator

    Jedinator Member

    Joined:
    Jul 10, 2011
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Thank you very much. My issue was resolved. Your help was appreciated :)
     
  10. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,448
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
Loading...

Share This Page