The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WordPress error caused by server config???

Discussion in 'General Discussion' started by whipworks, Apr 9, 2015.

  1. whipworks

    whipworks Well-Known Member

    Joined:
    Aug 19, 2014
    Messages:
    105
    Likes Received:
    1
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Hi. Getting this WP error. Talked to WordPress and they pointed out that it's an issue on the server side. Any thoughts?

    Warning: An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums. (WordPress could not establish a secure connection to WordPress.org. Please contact your server administrator.) in /home/domain/public_html/cn1950s/wp-admin/includes/translation-install.php on line 59

    Thanks in advance.
     
  2. madmanmachines

    madmanmachines Well-Known Member

    Joined:
    Nov 28, 2014
    Messages:
    94
    Likes Received:
    3
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    Did they provide any specific details? What does line 59 show of the file? Have you tried temporarily disabling your firewall?

    Thanks,
     
  3. whipworks

    whipworks Well-Known Member

    Joined:
    Aug 19, 2014
    Messages:
    105
    Likes Received:
    1
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    No specifics. All I can figure out is that the code I think points to showing up this error if it finds something wrong with another code. Posting the line codes to better explain it (I hope).

    $request = wp_remote_post( $url, $options );

    if ( $ssl && is_wp_error( $request ) ) {
    trigger_error( __( 'An unexpected error occurred. Something may be wrong with WordPress.org or this server&#8217;s configuration. If you continue to have problems, please try the <a href="https://wordpress.org/support/">support forums</a>.' ) . ' ' . __( '(WordPress could not establish a secure connection to WordPress.org. Please contact your server administrator.)' ), headers_sent() || WP_DEBUG ? E_USER_WARNING : E_USER_NOTICE );

    $request = wp_remote_post( $http_url, $options );

    I don't if I got this right, but is this failing because there's a missing file? Don't really have any knowledge in WordPress.
     
  4. madmanmachines

    madmanmachines Well-Known Member

    Joined:
    Nov 28, 2014
    Messages:
    94
    Likes Received:
    3
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    HI,

    It is difficult to help without much information or access to the server. Have you tried temporarily disabling your firewall? Also have you ensured curlssl is enabled in EasyApache?

    Thanks,
     
  5. EHR

    EHR Member

    Joined:
    Apr 18, 2012
    Messages:
    11
    Likes Received:
    2
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    Did you had issues while trying to install/update plugins or is it related to this function only ? If no 'over the net' installs/updates can be done the problem is (as @madmanmachines said) related to missing modules or firewall config.
     
  6. whipworks

    whipworks Well-Known Member

    Joined:
    Aug 19, 2014
    Messages:
    105
    Likes Received:
    1
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Additional info is that The Akismet spam filtering service is not communicating with the server. So I'm guessing @madmanmachines is right about missing modules or firewall config. Question now is, is this a fix that needs root access or is there such firewall setting on WHM that can be configured?
     
  7. madmanmachines

    madmanmachines Well-Known Member

    Joined:
    Nov 28, 2014
    Messages:
    94
    Likes Received:
    3
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    Hi,

    If you have access to EasyApache in WHM, then you can rebuild and ensure curlssl is enabled. Or you can look for a curlssl PHP test script for this purpose. For the firewall, you may check at WHM > Configserver Security & Firewall.

    Thanks,
     
  8. whipworks

    whipworks Well-Known Member

    Joined:
    Aug 19, 2014
    Messages:
    105
    Likes Received:
    1
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Hi,

    I've tried searching for that option on WHM, but it seems that one is missing.
     
  9. madmanmachines

    madmanmachines Well-Known Member

    Joined:
    Nov 28, 2014
    Messages:
    94
    Likes Received:
    3
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    Sounds like you need to contact your host
     
  10. whipworks

    whipworks Well-Known Member

    Joined:
    Aug 19, 2014
    Messages:
    105
    Likes Received:
    1
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Looks like when the CPanel servers go updated, everything went bonkers :(
     
  11. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page