The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

wordpress throwing error after apache upgrade to 2.4

Discussion in 'EasyApache' started by bhanuprasad1981, Feb 6, 2013.

  1. bhanuprasad1981

    bhanuprasad1981 Well-Known Member

    Joined:
    Aug 5, 2008
    Messages:
    222
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    after upgrading to apache 2.4 wordpress sites are throwing this error :-

    Code:
    Warning: preg_replace() [function.preg-replace]: Compilation failed: unknown option bit(s) set at offset -1 in /home/somesite/public_html/soemsite.com/wp-includes/shortcodes.php on line 257
    
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,834
    Likes Received:
    672
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Did you also update the version of PHP when you ran EasyApache? In addition, have you checked to see which versions of WordPress are installed on the websites displaying this error? You may want to ensure a recent version is installed so that it's compatible with the version of Apache and PHP installed on your system.

    Thank you.
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,834
    Likes Received:
    672
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Please also post the output of the following commands:

    Code:
    # /usr/local/cpanel/bin/rebuild_phpconf --current
    # ldd /usr/local/apache/modules/libphp5.so |grep pcre
    # /opt/pcre/bin/pcre-config --version
    # /usr/bin/pcre-config --version
    Thank you.
     
  4. Silence219

    Silence219 Registered

    Joined:
    Feb 10, 2013
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I have the same issue with Wordpress 3.5.1, I just updated to Apache 2.4.

    Code:
    # ldd /usr/local/apache/modules/libphp5.so |grep pcre
            libpcre.so.0 => /opt/pcre/lib/libpcre.so.0 (0x00007fe4fec32000)
    # /opt/pcre/bin/pcre-config --version
    8.21
    # /usr/bin/pcre-config --version
    7.8
    # /usr/local/cpanel/bin/rebuild_phpconf --current
    Available handlers: suphp dso cgi none
    DEFAULT PHP: 5
    PHP4 SAPI: none
    PHP5 SAPI: dso
    SUEXEC: enabled
    RUID2: enabled
     
  5. mike.b

    mike.b Registered

    Joined:
    Nov 30, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I'm having a similar issue with XenForo after upgrading to Apache 2.4 and PHP 5.4.11. This appears to be a PCRE-related issue, as reported on the XenForo forums.

    Apache 2.2 and PHP 5.4.11 work fine.
     
    #5 mike.b, Feb 10, 2013
    Last edited: Feb 10, 2013
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,834
    Likes Received:
    672
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  7. LeadDogGraphics

    LeadDogGraphics Well-Known Member

    Joined:
    Feb 25, 2012
    Messages:
    97
    Likes Received:
    1
    Trophy Points:
    8
    Location:
    West Palm Beach, FL
    cPanel Access Level:
    Root Administrator
    I'd like to know what comes of this once CP gets a chance to check it out.
     
  8. pmc

    pmc Member

    Joined:
    May 13, 2012
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I am getting the same errors and am having trouble locating a real solution.
     
  9. cPanelJamyn

    cPanelJamyn Social Engineer
    Staff Member

    Joined:
    Jan 29, 2009
    Messages:
    105
    Likes Received:
    2
    Trophy Points:
    0
    Hi,

    I'll look into reproducing this in-house later today, and will file an internal bug report on the issue. Thanks!
     
  10. icest

    icest Registered

    Joined:
    Apr 5, 2013
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
  11. icest

    icest Registered

    Joined:
    Apr 5, 2013
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    echo "/opt/pcre/lib/" >> /etc/ld.so.conf

    works for me
     
Loading...
Similar Threads - wordpress throwing error
  1. clubehost
    Replies:
    4
    Views:
    239

Share This Page