WordPress Toolkit Failed to update selected items. Decrypting an empty string is prohibited.

Operating System & Version
Centos 7.9.2009
cPanel & WHM Version
100.0.5

HowardE

Member
Aug 8, 2015
24
4
53
Florida
cPanel Access Level
Root Administrator
Attempting to update any WP Site from the toolkit show this error:

  • Failed to update selected items.
    Decrypting an empty string is prohibited.
and the install fails.

This error occurs when trying to update the WordPress version, however, many plugin updates are working through this feature. Why would updating the WP Version be an issue, but not for the plugins?

Using the help's suggestion to use CLI:

Code:
[root]# wp-toolkit --wp-cli -instance-id 1 -- core update
only works if I add --allow-root

Somewhat tedious for a few hundred sites. However, doesn't the Toolkit use the same CLI commands to retrieve the downloads and install the updates?

I know this is a vague question, but I'm looking for any suggestions as to how to solve this.
 

Attachments

Last edited:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
12,499
1,971
363
cPanel Access Level
Root Administrator
@Wallu - this doesn't seem to be a general cPanel issue that many users are running into, with is why @cPanelAnthony asked the OP to open a ticket so we can investigate. If you're seeing the same behavior, it would be best to open a ticket with our team so we can check the machine directly, and then post the ticket number here so I can update the thread once we have a resolution.
 

thowden

Well-Known Member
May 17, 2013
91
16
58
Australia
cPanel Access Level
Root Administrator
Hi

That error is triggered if Directory Privacy / htpasswd access is set for the Wordpress site.

This may or may not be the reason for the above error, but given that this thread appears to be the only one related to the error, this might help.

From the above quote " only works if I add --allow-root " that would possibly allow the Wordpress Toolkit to have direct server access to the site and bypass the .htpasswd / Directory Privacy setting.

Has anyone got a workaround other than "--allow-root" command line or per account disabling Directory Privacy, do updates, and re-enable ?